task-pandora-xfce: Added xwininfo and pandora-pndstore
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r53"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13 #  abiword \
14   evince \
15 #  claws-mail \
16   swfdec swfdec-gnome swfdec-mozilla \
17 #  gnumeric \   
18   networkmanager network-manager-applet netm-cli \ 
19   vnc x11vnc angstrom-x11vnc-xinit \
20   xchat \
21   links-x11 \
22   enchant \
23   aspell \
24   xwininfo \
25 #  xournal \
26 #  arora \
27 "
28
29 BLUETOOTH_GUI = " \
30   gnome-bluetooth \
31 "
32
33 IM_CLIENT = " \
34 #  pidgin \
35 #  libpurple-protocol-msn \
36 #  libpurple-protocol-yahoo \
37 #  libpurple-protocol-icq \
38 #  libpurple-protocol-aim \
39 "
40
41 DISPMAN = " \
42   slim \
43   slim-op-themes \
44 "
45
46 FONTS = " \
47   font-adobe-75dpi \
48   fontconfig fontconfig-utils font-util \
49   ttf-arphic-uming \
50   ttf-dejavu-common \
51   ttf-dejavu-sans \
52   ttf-dejavu-serif \
53   ttf-dejavu-sans-mono \
54   ttf-liberation-sans \
55   ttf-liberation-serif \
56   ttf-liberation-mono \
57   xorg-minimal-fonts \
58 "  
59
60 # Any default games we want to ship.
61 GAMES = " \
62 #  scummvm \
63 #  frozen-bubble \
64 #  gnome-games \  
65 #  numptyphysics \
66 "
67
68 GNOME_APPS = " \
69 #  gnome-mplayer \
70   gcalctool \ 
71   gnome-keyring gnome-keyring-pam-plugin \
72   gksu \
73 "
74
75 GSTREAMER = " \
76 #  gstreamer-ti \
77   gst-ffmpeg \
78   gst-omapfb \
79 #  gst-plugin-pulse \
80   gst-plugin-xvimagesink \
81   gst-plugins-base-meta \
82 #  gst-plugins-good-meta \
83 #  gst-plugins-bad-meta \
84 #  gst-plugins-ugly-meta \
85   gst-plugin-gles \
86 "
87
88 ICON_THEME = " \
89   hicolor-icon-theme \
90   elementary-icon-theme \
91   elementary-icon-theme-enable \
92 "
93
94 LAUNCHERS = " \
95 #  netbook-launcher-efl \
96   pandora-libpnd-minimenu \
97 #  pandora-pmenu \
98 "
99
100 PANDORA = " \
101   pandora-first-run-wizard hsetroot \
102   pandora-scripts \
103   pandora-wallpaper-official \
104   pandora-xfce-defaults \
105 #  pandora-midori-defaults midori \
106   libgles2d \
107   pandora-misc \
108   pandora-pndstore \
109 "
110
111 PERL = " \
112   perl \
113   task-perl-module-all \
114   libnet-dbus-perl \
115   libxml-parser-perl \
116   libxml-twig-perl \
117 "
118
119 PULSEAUDIO = " \
120 #  pulseaudio-alsa-wrapper \
121 #  pulseaudio-esd-wrapper \
122 #  pulseaudio-module-gconf \
123 #  libasound-module-ctl-pulse \
124 #  libasound-module-pcm-pulse \
125 "
126
127 PYTHON_LIBS = " \
128   python-shell \
129   python-pygtk \
130   python-pycairo \
131   gnome-vfs-plugin-http \
132   gnome-vfs-plugin-ftp \
133 "
134
135 QT_SELECTED = " qt4-x11-free \
136 "
137 # qt4-x11-free"
138 # qt4-x11-free-gles"
139
140 #PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
141
142 QT_SUPPORT = " \
143   ${QT_SELECTED} \
144   qt4-plugin-imageformat-jpeg \
145   qt4-plugin-imageformat-gif \
146 "
147
148 # We want all of the Qt metapackage (for dev use) without the demos/examples.
149 BAD_RECOMMENDATIONS += " \
150   ${QT_SELECTED}-demos \
151   ${QT_SELECTED}-examples \
152 "
153
154 TOTEM = " \
155 #  totem \
156 #  totem-browser-plugin \
157 #  totem-plugin-bemused \
158 #  totem-plugin-gromit \
159 #  totem-plugin-media-player-keys \
160 #  totem-plugin-ontop \
161 #  totem-plugin-properties \
162 #  totem-plugin-screensaver \
163 #  totem-plugin-skipto \
164 #  totem-plugin-thumbnail \
165 "
166
167 TOUCHSCREEN = " \
168   gtk-touchscreen-mode-enable \
169   libgtkstylus \
170 #  xinput-calibrator \
171 "
172
173 XFCE46_BASE = " \
174   xfce4-dev-tools \
175   xfwm4 \
176   xfwm4-theme-default \
177   xfce-utils \  
178   xfce4-session \     
179   xfconf \
180   xfdesktop \
181   xfce4-panel \
182   xfce4-power-manager \
183   \
184   gtk-xfce-engine \
185   \
186   xfce4-panel-plugin-actions \
187   xfce4-panel-plugin-clock \
188   xfce4-panel-plugin-iconbox \
189   xfce4-panel-plugin-launcher \
190   xfce4-panel-plugin-pager \
191   xfce4-panel-plugin-separator \
192   xfce4-panel-plugin-showdesktop \
193   xfce4-panel-plugin-systray \
194   xfce4-panel-plugin-tasklist \
195   xfce4-panel-plugin-windowlist \   
196   xfce4-settings \
197   xfce-terminal \
198   thunar \
199 "
200
201 XFCE46_EXTRAS = " \
202   xfce4-notifyd \
203   xfce4-mixer \
204   xfce4-appfinder \
205   xfce4-battery-plugin \
206   xfprint \    
207   orage \
208   squeeze \
209   ristretto \
210   mousepad \ 
211   gigolo \
212   xdotool \
213 "
214
215 XFCE_THEMES = " \
216   xfwm4-theme-daloa \
217   xfwm4-theme-moheli \
218   xfwm4-theme-kokodi \
219   xfwm4-theme-sassandra \
220   xfwm4-themes \
221 "
222
223 XSERVER_BASE = " \
224   ${XSERVER} \
225   dbus-x11 \
226   desktop-file-utils \
227   iso-codes \
228   mime-support \
229   notification-daemon inotify-tools \
230   xauth \
231   xdg-utils \
232   xhost \
233   xinetd \
234   xinit \
235   xlsfonts \
236   xrdb \
237   xrefresh \
238   xset \
239   xvinfo \
240   devilspie \
241   encodings \
242   xterm \
243   xmodmap \
244 "
245
246 ADD_LIBS = " \
247   libbonobo \
248   libetpan \
249   libfribidi \
250   libgsf \
251   libidn \
252   libxslt \
253   wv \
254   libsamplerate0 \
255   glibc-gconv-cp1252 \
256   glibc-gconv-ibm850 \
257   glibc-gconv-iso8859-15 \
258   
259
260
261 RDEPENDS_${PN} = " \
262   task-pandora-core \
263   angstrom-x11-base-depends \
264   ${ANGSTROM_EXTRA_INSTALL} \
265   ${APPS} \
266   ${BLUETOOTH_GUI} \
267   ${IM_CLIENT} \
268   ${DISPMAN} \
269   ${FONTS} \
270   ${GAMES} \  
271   ${GNOME_APPS} \
272   ${GSTREAMER} \
273   ${ICON_THEME} \
274   ${LAUNCHERS} \
275   ${PANDORA} \
276   ${PERL} \
277   ${PULSEAUDIO} \
278   ${PYTHON_LIBS} \
279   ${QT_SUPPORT} \
280   ${TOTEM} \
281   ${TOUCHSCREEN} \
282   ${XSERVER_BASE} \
283   ${XFCE46_BASE} \
284   ${XFCE46_EXTRAS} \
285   ${XFCE_THEMES} \
286   ${ADD_LIBS} \
287   \
288   rxvt-unicode \
289 #  xst \
290 #  suspend-desktop \
291 #  teleport \
292   gdk-pixbuf-loader-png \
293   gdk-pixbuf-loader-xpm \
294   gdk-pixbuf-loader-jpeg \
295   pango-module-basic-x \
296   pango-module-basic-fc \
297   xcursor-transparent-theme \   
298   xterm \
299   jaaa nmap iperf \
300 #  gnuplot \
301 "