elementary-icon-theme* : Add latest versions of elementary icon themes and convert...
authorDavid-John Willis <John.Willis@Distant-earth.com>
Tue, 2 Mar 2010 15:17:57 +0000 (15:17 +0000)
committerDavid-John Willis <John.Willis@Distant-earth.com>
Thu, 8 Apr 2010 07:19:43 +0000 (08:19 +0100)
recipes/elementary-icon-theme/elementary-icon-theme_2.2.bb
recipes/elementary-icon-theme/elementary-icon-theme_2.3.bb [new file with mode: 0644]
recipes/elementary-icon-theme/elementary-monochrome-icon-theme-enable.bb [new file with mode: 0644]
recipes/elementary-icon-theme/elementary-monochrome-icon-theme_2.3.bb [new file with mode: 0644]

index 81f1657..59a3d74 100644 (file)
@@ -4,15 +4,18 @@ HOMEPAGE = "http://www.elementary-project.com/"
 
 RDEPENDS = "gnome-icon-theme hicolor-icon-theme"
 
-PR = "r0"
+PR = "r1"
 
 # We have to get the icons from a mirror (LaunchPad) as DeviantArt has a download 
 # wrapper to stop simple HTTP gets :(.
 
 SRC_URI = " \
-  http://launchpad.net/elementaryicons/trunk/2.2/+download/elementary_2.2.tar.gz \
+  http://launchpad.net/elementaryicons/2.0/2.2/+download/elementary_2.2.tar.gz;name=archive \
 "
 
+SRC_URI[archive.md5sum] = "fb740a046d8d728613499a77b77bc1e2"
+SRC_URI[archive.sha256sum] = "49672fc965b30cc6c5c2589a1b72c5187a2d185e7f6d599968172fd694f28ea6"
+
 S = "${WORKDIR}/elementary_2.2"
 
 do_install() {
diff --git a/recipes/elementary-icon-theme/elementary-icon-theme_2.3.bb b/recipes/elementary-icon-theme/elementary-icon-theme_2.3.bb
new file mode 100644 (file)
index 0000000..d10a9a4
--- /dev/null
@@ -0,0 +1,36 @@
+SECTION = "x11/icons"
+DESCRIPTION = "Icon theme from the Elementary project"
+HOMEPAGE = "http://www.elementary-project.com/"
+
+RDEPENDS = "gnome-icon-theme hicolor-icon-theme"
+
+PR = "r0"
+
+# We have to get the icons from a mirror (LaunchPad) as DeviantArt has a download 
+# wrapper to stop simple HTTP gets :(.
+
+SRC_URI = " \
+  http://launchpad.net/elementaryicons/2.0/2.3/+download/elementary.tar.gz;name=archive \
+"
+
+SRC_URI[archive.md5sum] = "674a88984f55170c17298863f72dd34d"
+SRC_URI[archive.sha256sum] = "f7cacfd0e4d3c9ea1c84b29a4f2c75fa1066d6c7f9b41ca0b96ae033c23992a6"
+
+S = "${WORKDIR}/elementary"
+
+do_install() {
+        install -d ${D}${datadir}/icons/
+        install -d ${D}${datadir}/icons/elementary/
+        cp -r ${S}/* "${D}${datadir}/icons/elementary/"       
+}
+
+FILES_${PN} = "${datadir}/icons/elementary/"
+
+PACKAGE_ARCH = "all"
+
+pkg_postinst_${PN} () {
+  if [ "x$D" != "x" ]; then
+    exit 1
+  fi
+  gtk-update-icon-cache -q /usr/share/icons/elementary
+}
diff --git a/recipes/elementary-icon-theme/elementary-monochrome-icon-theme-enable.bb b/recipes/elementary-icon-theme/elementary-monochrome-icon-theme-enable.bb
new file mode 100644 (file)
index 0000000..ec7a989
--- /dev/null
@@ -0,0 +1,14 @@
+DESCRIPTION = "Enable elementary-monochrome-icon-theme in gtkrc"
+
+RDEPENDS = "elementary-monochrome-icon-theme"
+
+ALLOW_EMPTY_${PN} = "1"
+PACKAGE_ARCH = "all"
+
+pkg_postinst() {
+#!/bin/sh
+mkdir -p $D${sysconfdir}/gtk-2.0
+touch $D${sysconfdir}/gtk-2.0/gtkrc
+sed -i /gtk-icon-theme-name/d $D${sysconfdir}/gtk-2.0/gtkrc
+echo 'gtk-icon-theme-name = "elementary-monochrome"' >> $D${sysconfdir}/gtk-2.0/gtkrc
+}
diff --git a/recipes/elementary-icon-theme/elementary-monochrome-icon-theme_2.3.bb b/recipes/elementary-icon-theme/elementary-monochrome-icon-theme_2.3.bb
new file mode 100644 (file)
index 0000000..9bc6020
--- /dev/null
@@ -0,0 +1,36 @@
+SECTION = "x11/icons"
+DESCRIPTION = "Monochrome icon theme from the Elementary project"
+HOMEPAGE = "http://www.elementary-project.com/"
+
+RDEPENDS = "gnome-icon-theme hicolor-icon-theme"
+
+PR = "r0"
+
+# We have to get the icons from a mirror (LaunchPad) as DeviantArt has a download 
+# wrapper to stop simple HTTP gets :(.
+
+SRC_URI = " \
+  http://launchpad.net/elementaryicons/2.0/2.3/+download/elementary-monochrome.tar.gz;name=archive  \
+"
+
+SRC_URI[archive.md5sum] = "986a2475e9953450b37912d154bb325d"
+SRC_URI[archive.sha256sum] = "da461bd70b2fda633f26aa7495e1efc5d97815661799566f0a8accaea411272f"
+
+S = "${WORKDIR}/elementary-monochrome"
+
+do_install() {
+        install -d ${D}${datadir}/icons/
+        install -d ${D}${datadir}/icons/elementary-monochrome/
+        cp -r ${S}/* "${D}${datadir}/icons/elementary-monochrome/"
+}
+
+FILES_${PN} = "${datadir}/icons/elementary-monochrome/"
+
+PACKAGE_ARCH = "all"
+
+pkg_postinst_${PN} () {
+  if [ "x$D" != "x" ]; then
+    exit 1
+  fi
+  gtk-update-icon-cache -q /usr/share/icons/elementary-monochrome
+}