elementary-icon-theme* : Add latest versions of elementary icon themes and convert...
[openembedded.git] / recipes / elementary-icon-theme / elementary-icon-theme_2.3.bb
1 SECTION = "x11/icons"
2 DESCRIPTION = "Icon theme from the Elementary project"
3 HOMEPAGE = "http://www.elementary-project.com/"
4
5 RDEPENDS = "gnome-icon-theme hicolor-icon-theme"
6
7 PR = "r0"
8
9 # We have to get the icons from a mirror (LaunchPad) as DeviantArt has a download 
10 # wrapper to stop simple HTTP gets :(.
11
12 SRC_URI = " \
13   http://launchpad.net/elementaryicons/2.0/2.3/+download/elementary.tar.gz;name=archive \
14 "
15
16 SRC_URI[archive.md5sum] = "674a88984f55170c17298863f72dd34d"
17 SRC_URI[archive.sha256sum] = "f7cacfd0e4d3c9ea1c84b29a4f2c75fa1066d6c7f9b41ca0b96ae033c23992a6"
18
19 S = "${WORKDIR}/elementary"
20
21 do_install() {
22         install -d ${D}${datadir}/icons/
23         install -d ${D}${datadir}/icons/elementary/
24         cp -r ${S}/* "${D}${datadir}/icons/elementary/"       
25 }
26
27 FILES_${PN} = "${datadir}/icons/elementary/"
28
29 PACKAGE_ARCH = "all"
30
31 pkg_postinst_${PN} () {
32   if [ "x$D" != "x" ]; then
33     exit 1
34   fi
35   gtk-update-icon-cache -q /usr/share/icons/elementary
36 }