elementary-icon-theme* : Add latest versions of elementary icon themes and convert...
[openembedded.git] / recipes / elementary-icon-theme / elementary-monochrome-icon-theme_2.3.bb
1 SECTION = "x11/icons"
2 DESCRIPTION = "Monochrome icon theme from the Elementary project"
3 HOMEPAGE = "http://www.elementary-project.com/"
4
5 RDEPENDS = "gnome-icon-theme hicolor-icon-theme"
6
7 PR = "r0"
8
9 # We have to get the icons from a mirror (LaunchPad) as DeviantArt has a download 
10 # wrapper to stop simple HTTP gets :(.
11
12 SRC_URI = " \
13   http://launchpad.net/elementaryicons/2.0/2.3/+download/elementary-monochrome.tar.gz;name=archive  \
14 "
15
16 SRC_URI[archive.md5sum] = "986a2475e9953450b37912d154bb325d"
17 SRC_URI[archive.sha256sum] = "da461bd70b2fda633f26aa7495e1efc5d97815661799566f0a8accaea411272f"
18
19 S = "${WORKDIR}/elementary-monochrome"
20
21 do_install() {
22         install -d ${D}${datadir}/icons/
23         install -d ${D}${datadir}/icons/elementary-monochrome/
24         cp -r ${S}/* "${D}${datadir}/icons/elementary-monochrome/"
25 }
26
27 FILES_${PN} = "${datadir}/icons/elementary-monochrome/"
28
29 PACKAGE_ARCH = "all"
30
31 pkg_postinst_${PN} () {
32   if [ "x$D" != "x" ]; then
33     exit 1
34   fi
35   gtk-update-icon-cache -q /usr/share/icons/elementary-monochrome
36 }