task-pandora-xfce.bb: Added OpenBox and some needed programs for Gigolo
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index 1421a52..c6a0773 100755 (executable)
@@ -2,7 +2,7 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r55"
+PR = "r59"
 
 inherit task
 
@@ -22,6 +22,8 @@ APPS = " \
   enchant \
   aspell \
   xwininfo \
+  curl \
+  dosfstools \
 #  xournal \
 #  arora \
 "
@@ -132,15 +134,7 @@ PYTHON_LIBS = " \
   gnome-vfs-plugin-ftp \
 "
 
-#QT_SELECTED = " qt4-x11-free \
-#"
-# qt4-x11-free"
-# qt4-x11-free-gles"
-
-#PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
-
 QT_SUPPORT = " \
-  #${QT_SELECTED} \
  libqt3support4 \ 
  libqtassistantclient4 \ 
  libqtclucene4 \ 
@@ -150,50 +144,28 @@ QT_SUPPORT = " \
  libqtdesignercomponents4 \ 
  libqtgui4 \ 
  libqthelp4 \ 
- libqtnetwork4 \ 
- libqtopengl4 \ 
+ libqtnetwork4 \  
  libqtscript4 \ 
  libqtscripttools4 \ 
  libqtsql4 \ 
  libqtsvg4 \ 
  libqttest4 \ 
- libqtuitools4 \ 
  libqtwebkit4 \ 
- libqtxml4 \ 
- libqtxmlpatterns4 \ 
- libphonon4 \ 
- libqtmultimedia4 \ 
- libqtopenvg4 \ 
- libqtmediaservices4 \ 
- libqtdeclarative4 \ 
- libqtpvrqwswsegl4 \ 
+ libqtxml4 \  
  qt4-tools \ 
  qt4-assistant \ 
  qt4-common \ 
  qt4-dbus \ 
  qt4-designer \ 
  qt4-fonts \ 
- qt4-fonts-ttf-vera \ 
- qt4-fonts-ttf-dejavu \ 
- qt4-fonts-pfa \ 
- qt4-fonts-pfb \ 
- qt4-fonts-qpf \ 
  qt4-linguist \ 
- qt4-makeqpf \ 
  qt4-mkspecs \ 
  qt4-pixeltool \ 
- qt4-qmlviewer \ 
- qt4-xmlpatterns \ 
  qt4-qt3to4 \
  qt4-plugin-imageformat-jpeg \
  qt4-plugin-imageformat-gif \
 "
 
-# We want all of the Qt metapackage (for dev use) without the demos/examples.
-#BAD_RECOMMENDATIONS += " \
-#  ${QT_SELECTED}-demos \
-#  ${QT_SELECTED}-examples \
-#"
 
 TOTEM = " \
 #  totem \
@@ -254,6 +226,7 @@ XFCE46_EXTRAS = " \
   mousepad \ 
   gigolo \
   xdotool \
+  openbox \
 "
 
 XFCE_THEMES = " \
@@ -299,7 +272,8 @@ ADD_LIBS = " \
   glibc-gconv-cp1252 \
   glibc-gconv-ibm850 \
   glibc-gconv-iso8859-15 \
-  
+  gvfsd-sftp
+  sshfs-fuse
 " 
 
 RDEPENDS_${PN} = " \