1421a5256da6ec5104d8982517679afa8ac56290
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r55"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13 #  abiword \
14   evince \
15 #  claws-mail \
16   swfdec swfdec-gnome swfdec-mozilla \
17 #  gnumeric \   
18   networkmanager network-manager-applet \ 
19   vnc x11vnc angstrom-x11vnc-xinit \
20   xchat \
21   links-x11 \
22   enchant \
23   aspell \
24   xwininfo \
25 #  xournal \
26 #  arora \
27 "
28
29 BLUETOOTH_GUI = " \
30   gnome-bluetooth \
31 "
32
33 IM_CLIENT = " \
34 #  pidgin \
35 #  libpurple-protocol-msn \
36 #  libpurple-protocol-yahoo \
37 #  libpurple-protocol-icq \
38 #  libpurple-protocol-aim \
39 "
40
41 DISPMAN = " \
42   slim \
43   slim-op-themes \
44 "
45
46 FONTS = " \
47   font-adobe-75dpi \
48   fontconfig fontconfig-utils font-util \
49   ttf-arphic-uming \
50   ttf-dejavu-common \
51   ttf-dejavu-sans \
52   ttf-dejavu-serif \
53   ttf-dejavu-sans-mono \
54   ttf-liberation-sans \
55   ttf-liberation-serif \
56   ttf-liberation-mono \
57   xorg-minimal-fonts \
58 "  
59
60 # Any default games we want to ship.
61 GAMES = " \
62 #  scummvm \
63 #  frozen-bubble \
64 #  gnome-games \  
65 #  numptyphysics \
66 "
67
68 GNOME_APPS = " \
69 #  gnome-mplayer \
70   gcalctool \ 
71   gnome-keyring gnome-keyring-pam-plugin \
72   gksu \
73 "
74
75 GSTREAMER = " \
76 #  gstreamer-ti \
77   gst-ffmpeg \
78   gst-omapfb \
79 #  gst-plugin-pulse \
80   gst-plugin-xvimagesink \
81   gst-plugins-base-meta \
82 #  gst-plugins-good-meta \
83 #  gst-plugins-bad-meta \
84 #  gst-plugins-ugly-meta \
85   gst-plugin-gles \
86 "
87
88 ICON_THEME = " \
89   hicolor-icon-theme \
90   elementary-icon-theme \
91   elementary-icon-theme-enable \
92 "
93
94 LAUNCHERS = " \
95 #  netbook-launcher-efl \
96   pandora-libpnd-minimenu \
97 #  pandora-pmenu \
98 "
99
100 PANDORA = " \
101   pandora-first-run-wizard hsetroot \
102   pandora-scripts \
103   pandora-wallpaper-official \
104   pandora-xfce-defaults \
105 #  pandora-midori-defaults midori \
106   libgles2d \
107   pandora-misc \
108   pandora-pndstore \
109 "
110
111 PERL = " \
112   perl \
113   task-perl-module-all \
114   libnet-dbus-perl \
115   libxml-parser-perl \
116   libxml-twig-perl \
117 "
118
119 PULSEAUDIO = " \
120 #  pulseaudio-alsa-wrapper \
121 #  pulseaudio-esd-wrapper \
122 #  pulseaudio-module-gconf \
123 #  libasound-module-ctl-pulse \
124 #  libasound-module-pcm-pulse \
125 "
126
127 PYTHON_LIBS = " \
128   python-shell \
129   python-pygtk \
130   python-pycairo \
131   gnome-vfs-plugin-http \
132   gnome-vfs-plugin-ftp \
133 "
134
135 #QT_SELECTED = " qt4-x11-free \
136 #"
137 # qt4-x11-free"
138 # qt4-x11-free-gles"
139
140 #PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
141
142 QT_SUPPORT = " \
143   #${QT_SELECTED} \
144  libqt3support4 \ 
145  libqtassistantclient4 \ 
146  libqtclucene4 \ 
147  libqtcore4 \ 
148  libqtdbus4 \ 
149  libqtdesigner4 \ 
150  libqtdesignercomponents4 \ 
151  libqtgui4 \ 
152  libqthelp4 \ 
153  libqtnetwork4 \ 
154  libqtopengl4 \ 
155  libqtscript4 \ 
156  libqtscripttools4 \ 
157  libqtsql4 \ 
158  libqtsvg4 \ 
159  libqttest4 \ 
160  libqtuitools4 \ 
161  libqtwebkit4 \ 
162  libqtxml4 \ 
163  libqtxmlpatterns4 \ 
164  libphonon4 \ 
165  libqtmultimedia4 \ 
166  libqtopenvg4 \ 
167  libqtmediaservices4 \ 
168  libqtdeclarative4 \ 
169  libqtpvrqwswsegl4 \ 
170  qt4-tools \ 
171  qt4-assistant \ 
172  qt4-common \ 
173  qt4-dbus \ 
174  qt4-designer \ 
175  qt4-fonts \ 
176  qt4-fonts-ttf-vera \ 
177  qt4-fonts-ttf-dejavu \ 
178  qt4-fonts-pfa \ 
179  qt4-fonts-pfb \ 
180  qt4-fonts-qpf \ 
181  qt4-linguist \ 
182  qt4-makeqpf \ 
183  qt4-mkspecs \ 
184  qt4-pixeltool \ 
185  qt4-qmlviewer \ 
186  qt4-xmlpatterns \ 
187  qt4-qt3to4 \
188  qt4-plugin-imageformat-jpeg \
189  qt4-plugin-imageformat-gif \
190 "
191
192 # We want all of the Qt metapackage (for dev use) without the demos/examples.
193 #BAD_RECOMMENDATIONS += " \
194 #  ${QT_SELECTED}-demos \
195 #  ${QT_SELECTED}-examples \
196 #"
197
198 TOTEM = " \
199 #  totem \
200 #  totem-browser-plugin \
201 #  totem-plugin-bemused \
202 #  totem-plugin-gromit \
203 #  totem-plugin-media-player-keys \
204 #  totem-plugin-ontop \
205 #  totem-plugin-properties \
206 #  totem-plugin-screensaver \
207 #  totem-plugin-skipto \
208 #  totem-plugin-thumbnail \
209 "
210
211 TOUCHSCREEN = " \
212   gtk-touchscreen-mode-enable \
213   libgtkstylus \
214 #  xinput-calibrator \
215 "
216
217 XFCE46_BASE = " \
218   xfce4-dev-tools \
219   xfwm4 \
220   xfwm4-theme-default \
221   xfce-utils \  
222   xfce4-session \     
223   xfconf \
224   xfdesktop \
225   xfce4-panel \
226   xfce4-power-manager \
227   \
228   gtk-xfce-engine \
229   \
230   xfce4-panel-plugin-actions \
231   xfce4-panel-plugin-clock \
232   xfce4-panel-plugin-iconbox \
233   xfce4-panel-plugin-launcher \
234   xfce4-panel-plugin-pager \
235   xfce4-panel-plugin-separator \
236   xfce4-panel-plugin-showdesktop \
237   xfce4-panel-plugin-systray \
238   xfce4-panel-plugin-tasklist \
239   xfce4-panel-plugin-windowlist \   
240   xfce4-settings \
241   xfce-terminal \
242   thunar \
243 "
244
245 XFCE46_EXTRAS = " \
246   xfce4-notifyd \
247   xfce4-mixer \
248   xfce4-appfinder \
249   xfce4-battery-plugin \
250   xfprint \    
251   orage \
252   squeeze \
253   ristretto \
254   mousepad \ 
255   gigolo \
256   xdotool \
257 "
258
259 XFCE_THEMES = " \
260   xfwm4-theme-daloa \
261   xfwm4-theme-moheli \
262   xfwm4-theme-kokodi \
263   xfwm4-theme-sassandra \
264   xfwm4-themes \
265 "
266
267 XSERVER_BASE = " \
268   ${XSERVER} \
269   dbus-x11 \
270   desktop-file-utils \
271   iso-codes \
272   mime-support \
273   notification-daemon inotify-tools \
274   xauth \
275   xdg-utils \
276   xhost \
277   xinetd \
278   xinit \
279   xlsfonts \
280   xrdb \
281   xrefresh \
282   xset \
283   xvinfo \
284   devilspie \
285   encodings \
286   xterm \
287   xmodmap \
288 "
289
290 ADD_LIBS = " \
291   libbonobo \
292   libetpan \
293   libfribidi \
294   libgsf \
295   libidn \
296   libxslt \
297   wv \
298   libsamplerate0 \
299   glibc-gconv-cp1252 \
300   glibc-gconv-ibm850 \
301   glibc-gconv-iso8859-15 \
302   
303
304
305 RDEPENDS_${PN} = " \
306   task-pandora-core \
307   angstrom-x11-base-depends \
308   ${ANGSTROM_EXTRA_INSTALL} \
309   ${APPS} \
310   ${BLUETOOTH_GUI} \
311   ${IM_CLIENT} \
312   ${DISPMAN} \
313   ${FONTS} \
314   ${GAMES} \  
315   ${GNOME_APPS} \
316   ${GSTREAMER} \
317   ${ICON_THEME} \
318   ${LAUNCHERS} \
319   ${PANDORA} \
320   ${PERL} \
321   ${PULSEAUDIO} \
322   ${PYTHON_LIBS} \
323   ${QT_SUPPORT} \
324   ${TOTEM} \
325   ${TOUCHSCREEN} \
326   ${XSERVER_BASE} \
327   ${XFCE46_BASE} \
328   ${XFCE46_EXTRAS} \
329   ${XFCE_THEMES} \
330   ${ADD_LIBS} \
331   \
332   rxvt-unicode \
333 #  xst \
334 #  suspend-desktop \
335 #  teleport \
336   gdk-pixbuf-loader-png \
337   gdk-pixbuf-loader-xpm \
338   gdk-pixbuf-loader-jpeg \
339   pango-module-basic-x \
340   pango-module-basic-fc \
341   xcursor-transparent-theme \   
342   xterm \
343   jaaa nmap iperf \
344 #  gnuplot \
345 "