Merge branch 'master' of git://git.openpandora.org/openpandora.oe
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r36"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13   abiword \
14   evince \
15   claws-mail \
16   swfdec swfdec-gnome swfdec-mozilla \
17 #  firefox \
18   gnumeric \   
19 #  gimp \
20   networkmanager network-manager-applet \ 
21 #  synergy \
22   vnc x11vnc angstrom-x11vnc-xinit \
23   xchat \
24 #  xournal \
25   arora \
26 "
27
28 BLUETOOTH_GUI = " \
29   gnome-bluetooth \
30 "
31
32 IM_CLIENT = " \
33   pidgin \
34   libpurple-protocol-msn \
35   libpurple-protocol-yahoo \
36   libpurple-protocol-icq \
37   libpurple-protocol-aim \
38 "
39
40 DISPMAN = " \
41   slim \
42   slim-op-themes \
43 "
44
45 FONTS = " \
46   font-adobe-75dpi \
47   fontconfig fontconfig-utils font-util \
48   ttf-arphic-uming \
49   ttf-dejavu-common \
50   ttf-dejavu-sans \
51   ttf-dejavu-serif \
52   ttf-dejavu-sans-mono \
53   ttf-liberation-sans \
54   ttf-liberation-serif \
55   ttf-liberation-mono \
56   xorg-minimal-fonts \
57 "  
58
59 # Any default games we want to ship.
60 GAMES = " \
61 #  scummvm \
62 #  frozen-bubble \
63 #  gnome-games \  
64 #  numptyphysics \
65 "
66
67 GNOME_APPS = " \
68 #  gnome-mplayer \
69 #  gcalctool \ 
70   gnome-keyring gnome-keyring-pam-plugin \
71   gksu \
72 "
73
74 GNOME_GTK = " \
75 #  gnome-icon-theme \
76 #  angstrom-gnome-icon-theme-enable \
77 "
78
79 GSTREAMER = " \
80 #  gstreamer-ti \
81   gst-ffmpeg \
82   gst-omapfb \
83 #  gst-plugin-pulse \
84   gst-plugin-xvimagesink \
85   gst-plugins-base-meta \
86 #  gst-plugins-good-meta \
87 #  gst-plugins-bad-meta \
88 #  gst-plugins-ugly-meta \
89   gst-plugin-gles \
90 "
91
92 ICON_THEME = " \
93   hicolor-icon-theme \
94   elementary-icon-theme \
95   elementary-icon-theme-enable \
96 "
97
98 LAUNCHERS = " \
99 #  netbook-launcher-efl \
100   pandora-libpnd-minimenu \
101   pandora-pmenu \
102 "
103
104 PANDORA = " \
105   pandora-first-run-wizard hsetroot \
106   pandora-scripts \
107   pandora-wallpaper-official pandora-wallpaper-community \
108   pandora-xfce-defaults \
109   pandora-midori-defaults midori \
110   libgles2d \
111   pandora-misc \
112 "
113
114 PERL = " \
115   perl \
116   task-perl-module-all \
117   libnet-dbus-perl \
118   libxml-parser-perl \
119   libxml-twig-perl \
120 "
121
122 PULSEAUDIO = " \
123 #  pulseaudio-alsa-wrapper \
124 #  pulseaudio-esd-wrapper \
125 #  pulseaudio-module-gconf \
126 #  libasound-module-ctl-pulse \
127 #  libasound-module-pcm-pulse \
128 "
129
130 PYTHON_LIBS = " \
131   python-shell \
132   python-pygtk \
133   python-pycairo \
134   gnome-vfs-plugin-http \
135   gnome-vfs-plugin-ftp \
136 "
137
138 QT_SELECTED = " qt4-x11-free \
139 "
140 # qt4-x11-free"
141 # qt4-x11-free-gles"
142
143 #PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
144
145 QT_SUPPORT = " \
146   ${QT_SELECTED} \
147   qt4-plugin-imageformat-jpeg \
148   qt4-plugin-imageformat-gif \
149 "
150
151 # We want all of the Qt metapackage (for dev use) without the demos/examples.
152 BAD_RRECOMMENDS += " \
153   ${QT_SELECTED}-demos \
154   ${QT_SELECTED}-examples \
155 "
156
157 TOTEM = " \
158 #  totem \
159 #  totem-browser-plugin \
160 #  totem-plugin-bemused \
161 #  totem-plugin-gromit \
162 #  totem-plugin-media-player-keys \
163 #  totem-plugin-ontop \
164 #  totem-plugin-properties \
165 #  totem-plugin-screensaver \
166 #  totem-plugin-skipto \
167 #  totem-plugin-thumbnail \
168 "
169
170 TOUCHSCREEN = " \
171   gtk-touchscreen-mode-enable \
172   libgtkstylus \
173 #  xinput-calibrator \
174 "
175
176 XFCE46_BASE = " \
177   xfce4-dev-tools \
178   xfwm4 \
179   xfwm4-theme-default \
180   xfce-utils \  
181   xfce4-session \     
182   xfconf \
183   xfdesktop \
184   xfce4-panel \
185   xfce4-power-manager \
186   \
187   gtk-xfce-engine \
188   \
189   xfce4-panel-plugin-actions \
190   xfce4-panel-plugin-clock \
191   xfce4-panel-plugin-iconbox \
192   xfce4-panel-plugin-launcher \
193   xfce4-panel-plugin-pager \
194   xfce4-panel-plugin-separator \
195   xfce4-panel-plugin-showdesktop \
196   xfce4-panel-plugin-systray \
197   xfce4-panel-plugin-tasklist \
198   xfce4-panel-plugin-windowlist \   
199   xfce4-settings \
200   xfce-terminal \
201   thunar \
202 "
203
204 XFCE46_EXTRAS = " \
205   xfce4-notifyd \
206   xfce4-mixer \
207   xfce4-appfinder \
208   xfce4-battery-plugin \
209   xfprint \    
210   orage \
211   squeeze \
212   ristretto \
213   mousepad \ 
214   gigolo \
215 "
216
217 XFCE_THEMES = " \
218   xfwm4-theme-daloa \
219   xfwm4-theme-moheli \
220   xfwm4-theme-kokodi \
221   xfwm4-theme-sassandra \
222   xfwm4-themes \
223 "
224
225 XSERVER_BASE = " \
226   ${XSERVER} \
227   dbus-x11 \
228   desktop-file-utils \
229   iso-codes \
230   mime-support \
231   notification-daemon inotify-tools \
232   xauth \
233   xdg-utils \
234   xhost \
235   xinetd \
236   xinit \
237   xlsfonts \
238   xrdb \
239   xrefresh \
240   xset \
241   xvinfo \
242   devilspie \
243   encodings \
244   xterm \
245   xmodmap \
246 "
247
248 RDEPENDS_${PN} = " \
249   task-pandora-core \
250   angstrom-x11-base-depends \
251   ${ANGSTROM_EXTRA_INSTALL} \
252   ${APPS} \
253   ${BLUETOOTH_GUI} \
254   ${IM_CLIENT} \
255   ${DISPMAN} \
256   ${FONTS} \
257   ${GAMES} \  
258   ${GNOME_GTK} \
259   ${GNOME_APPS} \
260   ${GSTREAMER} \
261   ${ICON_THEME} \
262   ${LAUNCHERS} \
263   ${PANDORA} \
264   ${PERL} \
265   ${PULSEAUDIO} \
266   ${PYTHON_LIBS} \
267   ${QT_SUPPORT} \
268   ${TOTEM} \
269   ${TOUCHSCREEN} \
270   ${XSERVER_BASE} \
271   ${XFCE46_BASE} \
272   ${XFCE46_EXTRAS} \
273   ${XFCE_THEMES} \
274   \
275   rxvt-unicode \
276 #  xst \
277 #  suspend-desktop \
278 #  teleport \
279   gdk-pixbuf-loader-png \
280   gdk-pixbuf-loader-xpm \
281   gdk-pixbuf-loader-jpeg \
282   pango-module-basic-x \
283   pango-module-basic-fc \
284   xcursor-transparent-theme \   
285   xterm \
286   jaaa nmap iperf \
287 #  gnuplot \
288 "