task-pandora-xfce: Added the new pandora-lcd-state stuff
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r21"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13   abiword \
14   claws-mail \
15   swfdec swfdec-gnome swfdec-mozilla \
16 #  firefox \
17   gnumeric \   
18 #  gimp \
19   networkmanager network-manager-applet \ 
20 #  synergy \
21   vnc x11vnc angstrom-x11vnc-xinit \
22   xchat \
23   xournal \
24   arora \
25 "
26
27 BLUETOOTH_GUI = " \
28   blueman \
29   gnome-bluetooth \
30 "
31
32 IM_CLIENT = " \
33   pidgin \
34   libpurple-protocol-msn \
35   libpurple-protocol-yahoo \
36   libpurple-protocol-icq \
37   libpurple-protocol-aim \
38 "
39
40 DISPMAN = " \
41   slim \
42   slim-op-themes \
43 "
44
45 FONTS = " \
46   font-adobe-75dpi \
47   fontconfig fontconfig-utils font-util \
48   ttf-arphic-uming \
49   ttf-dejavu-common \
50   ttf-dejavu-sans \
51   ttf-dejavu-serif \
52   ttf-dejavu-sans-mono \
53   ttf-liberation-sans \
54   ttf-liberation-serif \
55   ttf-liberation-mono \
56   xorg-minimal-fonts \
57 "  
58
59 # Any default games we want to ship.
60 GAMES = " \
61 #  scummvm \
62 #  frozen-bubble \
63 #  gnome-games \  
64   numptyphysics \
65 "
66
67 GNOME_APPS = " \
68   gnome-mplayer \
69 #  gcalctool \ 
70   gnome-keyring gnome-keyring-pam-plugin \
71   gksu \
72 "
73
74 GNOME_GTK = " \
75 #  gnome-icon-theme \
76 #  angstrom-gnome-icon-theme-enable \
77 "
78
79 GSTREAMER = " \
80 #  gstreamer-ti \
81   gst-ffmpeg \
82   gst-omapfb \
83 #  gst-plugin-pulse \
84   gst-plugin-xvimagesink \
85   gst-plugins-base-meta \
86   gst-plugins-good-meta \
87   gst-plugins-bad-meta \
88 #  gst-plugins-ugly-meta \
89   gst-plugin-gles \
90 "
91
92 ICON_THEME = " \
93   hicolor-icon-theme \
94   elementary-icon-theme \
95   elementary-icon-theme-enable \
96 "
97
98 LAUNCHERS = " \
99 #  netbook-launcher-efl \
100   pandora-libpnd-minimenu \
101   pandora-pmenu \
102 "
103
104 PANDORA = " \
105   pandora-first-run-wizard hsetroot \
106   pandora-scripts \
107   pandora-lcd-state \
108   pandora-wallpaper-official pandora-wallpaper-community \
109   pandora-xfce-defaults \
110   pandora-xmms-defaults xmms \
111 #  pandora-midori-defaults midori \
112   libgles2d \
113 "
114
115 PERL = " \
116   perl \
117   task-perl-module-all \
118   libnet-dbus-perl \
119   libxml-parser-perl \
120   libxml-twig-perl \
121 "
122
123 PULSEAUDIO = " \
124 #  pulseaudio-alsa-wrapper \
125 #  pulseaudio-esd-wrapper \
126 #  pulseaudio-module-gconf \
127 #  libasound-module-ctl-pulse \
128 #  libasound-module-pcm-pulse \
129 "
130
131 QT_SELECTED = " qt4-x11-free \
132 "
133 # qt4-x11-free"
134 # qt4-x11-free-gles"
135
136 #PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
137
138 QT_SUPPORT = " \
139   ${QT_SELECTED} \
140   qt4-plugin-imageformat-png \
141   qt4-plugin-imageformat-jpeg \
142   qt4-plugin-imageformat-gif \
143 "
144
145 # We want all of the Qt metapackage (for dev use) without the demos/examples.
146 BAD_RRECOMMENDS += " \
147   ${QT_SELECTED}-demos \
148   ${QT_SELECTED}-examples \
149 "
150
151 TOTEM = " \
152   totem \
153   totem-browser-plugin \
154   totem-plugin-bemused \
155   totem-plugin-gromit \
156   totem-plugin-media-player-keys \
157   totem-plugin-ontop \
158   totem-plugin-properties \
159   totem-plugin-screensaver \
160   totem-plugin-skipto \
161   totem-plugin-thumbnail \
162 "
163
164 TOUCHSCREEN = " \
165   gtk-touchscreen-mode-enable \
166   libgtkstylus \
167   xinput-calibrator \
168 "
169
170 XFCE46_BASE = " \
171   xfce4-dev-tools \
172   xfwm4 \
173   xfwm4-theme-default \
174   xfce-utils \  
175   xfce4-session \     
176   xfconf \
177   xfdesktop \
178   xfce4-panel \
179   xfce4-power-manager \
180   \
181   gtk-xfce-engine \
182   \
183   xfce4-panel-plugin-actions \
184   xfce4-panel-plugin-clock \
185   xfce4-panel-plugin-iconbox \
186   xfce4-panel-plugin-launcher \
187   xfce4-panel-plugin-pager \
188   xfce4-panel-plugin-separator \
189   xfce4-panel-plugin-showdesktop \
190   xfce4-panel-plugin-systray \
191   xfce4-panel-plugin-tasklist \
192   xfce4-panel-plugin-windowlist \   
193   xfce4-settings \
194   xfce-terminal \
195   thunar \
196 "
197
198 XFCE46_EXTRAS = " \
199   xfce4-notifyd \
200   xfce4-mixer \
201   xfce4-appfinder \
202   xfce4-battery-plugin \
203   xfprint \    
204   orage \
205   squeeze \
206   ristretto \
207   mousepad \ 
208   gigolo \
209 "
210
211 XFCE_THEMES = " \
212   xfwm4-theme-daloa \
213   xfwm4-theme-moheli \
214 #  xfwm4-theme-default-4.0 \
215 #  xfwm4-theme-default-4.2 \
216 #  xfwm4-theme-default-4.4 \
217   xfwm4-theme-kokodi \
218   xfwm4-theme-sassandra \
219 #  xfwm4-theme-stoneage \
220 #  xfwm4-theme-therapy \
221 #  xfwm4-theme-tyrex \
222 #  xfwm4-theme-wallis \  
223   xfwm4-themes \
224 "
225
226 XSERVER_BASE = " \
227   ${XSERVER} \
228   dbus-x11 \
229   desktop-file-utils \
230   iso-codes \
231   mime-support \
232   notification-daemon inotify-tools \
233   xauth \
234   xdg-utils \
235   xhost \
236   xinetd \
237   xinit \
238   xlsfonts \
239   xrdb \
240   xrefresh \
241   xset \
242   xvinfo \
243   devilspie \
244   encodings \
245   xterm \
246   xmodmap \
247 "
248
249 RDEPENDS_${PN} = " \
250   task-pandora-core \
251   angstrom-x11-base-depends \
252   ${ANGSTROM_EXTRA_INSTALL} \
253   ${APPS} \
254   ${BLUETOOTH_GUI} \
255   ${IM_CLIENT} \
256   ${DISPMAN} \
257   ${FONTS} \
258   ${GAMES} \  
259   ${GNOME_GTK} \
260   ${GNOME_APPS} \
261   ${GSTREAMER} \
262   ${ICON_THEME} \
263   ${LAUNCHERS} \
264   ${PANDORA} \
265   ${PERL} \
266   ${PULSEAUDIO} \
267   ${QT_SUPPORT} \
268   ${TOTEM} \
269   ${TOUCHSCREEN} \
270   ${XSERVER_BASE} \
271   ${XFCE46_BASE} \
272   ${XFCE46_EXTRAS} \
273   ${XFCE_THEMES} \
274   \
275   rxvt-unicode \
276 #  xst \
277 #  suspend-desktop \
278 #  teleport \
279   gdk-pixbuf-loader-png \
280   gdk-pixbuf-loader-xpm \
281   gdk-pixbuf-loader-jpeg \
282   pango-module-basic-x \
283   pango-module-basic-fc \
284   xcursor-transparent-theme \   
285   xterm xmms \
286   jaaa nmap iperf \
287 #  gnuplot \
288 "