vairous: add in local updates for tasks/images.
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r3.1"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   abiword \
13   cheese \
14   claws-mail \
15   epiphany epiphany-extensions \
16   swfdec swfdec-gnome swfdec-mozilla \
17   evince \
18   gcalctool \
19   gedit \
20   gimp \
21   gnome-games \
22   gnome-mplayer \
23   gnumeric \
24   gphoto2 \
25   gthumb \
26   pidgin \
27   synergy \
28   vnc \
29   x11vnc angstrom-x11vnc-xinit \
30   xmms \
31   xterm \
32 "
33
34 FONTS = " \
35   font-adobe-75dpi \
36   fontconfig fontconfig-utils font-util \
37   ttf-arphic-uming \
38   ttf-dejavu-common \
39   ttf-dejavu-sans \
40   ttf-dejavu-serif \
41   ttf-dejavu-sans-mono \
42   ttf-liberation-sans \
43   ttf-liberation-serif \
44   ttf-liberation-mono \
45   xorg-minimal-fonts \
46 "  
47
48 GSTREAMER = " \
49   gst-ffmpeg \
50   gst-omapfb \
51   gst-plugin-pulse \
52   gst-plugins-base-meta \
53   gst-plugins-good-meta \
54   gst-plugins-bad-meta \
55 #  gst-plugins-ugly-meta \
56 "
57
58 PERL = " \
59   perl \
60 #  task-perl-module-all \
61 #  libnet-dbus-perl \
62   libxml-parser-perl \
63   libxml-twig-perl \
64 "
65
66 PULSEAUDIO = " \
67   pulseaudio-alsa-wrapper \
68   pulseaudio-esd-wrapper \
69   pulseaudio-module-gconf \
70   libasound-module-ctl-pulse \
71   libasound-module-pcm-pulse \
72 "
73
74 XSERVER_BASE = " \
75   ${XSERVER} \
76   dbus-x11 \
77   desktop-file-utils \
78   iso-codes \
79   mime-support \
80   notification-daemon inotify-tools \
81   xauth \
82 #  xdg-utils \
83   xhost \
84   xinetd \
85   xinit \
86   xlsfonts \
87   xrdb \
88   xrefresh \
89   xset \
90   xvinfo \
91 "
92
93 RDEPENDS_${PN} = " \
94   task-pandora-core \
95   ${ANGSTROM_EXTRA_INSTALL} \
96   ${APPS} \
97   ${FONTS} \
98   ${GSTREAMER} \
99   ${PERL} \
100   ${PULSEAUDIO} \
101   ${XSERVER_BASE} \
102         \
103         angstrom-x11-base-depends \
104         \
105 #       pandora-auto-startx \
106 #       pandora-first-run-wizard \
107         \
108         task-xfce46-base \
109         task-xfce46-extras \    
110         \
111 #       gnome-packagekit \
112         \
113         rxvt-unicode \
114         xkbd \
115         xst \
116         xhost \
117         xrdb \
118         libgtkstylus \
119         suspend-desktop \
120         teleport \
121         xauth \
122         gdk-pixbuf-loader-png \
123         gdk-pixbuf-loader-xpm \
124         gdk-pixbuf-loader-jpeg \
125         pango-module-basic-x \
126         pango-module-basic-fc \
127         gpe-theme-clearlooks \
128         xcursor-transparent-theme \     
129         angstrom-zeroconf-audio \
130         angstrom-led-config \   
131         mime-support \
132         xterm xmms \
133         firefox \
134         hicolor-icon-theme gnome-icon-theme \
135         jaaa nmap iperf gnuplot \
136         abiword \
137         gnumeric \
138         gimp \
139         pidgin \
140         gnome-games \
141         stalonetray \
142         synergy \
143         x11vnc angstrom-x11vnc-xinit \
144         angstrom-gnome-icon-theme-enable \
145         networkmanager network-manager-applet \
146         gnome-bluetooth \
147 "