Merge branch 'master' of git://git.openpandora.org/openpandora.oe
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r25"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13   abiword \
14   claws-mail \
15   swfdec swfdec-gnome swfdec-mozilla \
16 #  firefox \
17   gnumeric \   
18 #  gimp \
19   networkmanager network-manager-applet \ 
20 #  synergy \
21   vnc x11vnc angstrom-x11vnc-xinit \
22   xchat \
23 #  xournal \
24   arora \
25 "
26
27 BLUETOOTH_GUI = " \
28   blueman \
29   gnome-bluetooth \
30 "
31
32 IM_CLIENT = " \
33   pidgin \
34   libpurple-protocol-msn \
35   libpurple-protocol-yahoo \
36   libpurple-protocol-icq \
37   libpurple-protocol-aim \
38 "
39
40 DISPMAN = " \
41   slim \
42   slim-op-themes \
43 "
44
45 FONTS = " \
46   font-adobe-75dpi \
47   fontconfig fontconfig-utils font-util \
48   ttf-arphic-uming \
49   ttf-dejavu-common \
50   ttf-dejavu-sans \
51   ttf-dejavu-serif \
52   ttf-dejavu-sans-mono \
53   ttf-liberation-sans \
54   ttf-liberation-serif \
55   ttf-liberation-mono \
56   xorg-minimal-fonts \
57 "  
58
59 # Any default games we want to ship.
60 GAMES = " \
61 #  scummvm \
62 #  frozen-bubble \
63 #  gnome-games \  
64 #  numptyphysics \
65 "
66
67 GNOME_APPS = " \
68 #  gnome-mplayer \
69 #  gcalctool \ 
70   gnome-keyring gnome-keyring-pam-plugin \
71   gksu \
72 "
73
74 GNOME_GTK = " \
75 #  gnome-icon-theme \
76 #  angstrom-gnome-icon-theme-enable \
77 "
78
79 GSTREAMER = " \
80 #  gstreamer-ti \
81 #  gst-ffmpeg \
82   gst-omapfb \
83 #  gst-plugin-pulse \
84   gst-plugin-xvimagesink \
85 #  gst-plugins-base-meta \
86 #  gst-plugins-good-meta \
87 #  gst-plugins-bad-meta \
88 #  gst-plugins-ugly-meta \
89   gst-plugin-gles \
90 "
91
92 ICON_THEME = " \
93   hicolor-icon-theme \
94   elementary-icon-theme \
95   elementary-icon-theme-enable \
96 "
97
98 LAUNCHERS = " \
99 #  netbook-launcher-efl \
100   pandora-libpnd-minimenu \
101   pandora-pmenu \
102 "
103
104 PANDORA = " \
105   pandora-first-run-wizard hsetroot \
106   pandora-scripts \
107   pandora-wallpaper-official pandora-wallpaper-community \
108   pandora-xfce-defaults \
109   pandora-midori-defaults midori \
110   libgles2d \
111   pandora-misc \
112 "
113
114 PERL = " \
115   perl \
116   task-perl-module-all \
117   libnet-dbus-perl \
118   libxml-parser-perl \
119   libxml-twig-perl \
120 "
121
122 PULSEAUDIO = " \
123 #  pulseaudio-alsa-wrapper \
124 #  pulseaudio-esd-wrapper \
125 #  pulseaudio-module-gconf \
126 #  libasound-module-ctl-pulse \
127 #  libasound-module-pcm-pulse \
128 "
129
130 QT_SELECTED = " qt4-x11-free \
131 "
132 # qt4-x11-free"
133 # qt4-x11-free-gles"
134
135 #PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
136
137 QT_SUPPORT = " \
138   ${QT_SELECTED} \
139   qt4-plugin-imageformat-jpeg \
140   qt4-plugin-imageformat-gif \
141 "
142
143 # We want all of the Qt metapackage (for dev use) without the demos/examples.
144 BAD_RRECOMMENDS += " \
145   ${QT_SELECTED}-demos \
146   ${QT_SELECTED}-examples \
147 "
148
149 TOTEM = " \
150 #  totem \
151 #  totem-browser-plugin \
152 #  totem-plugin-bemused \
153 #  totem-plugin-gromit \
154 #  totem-plugin-media-player-keys \
155 #  totem-plugin-ontop \
156 #  totem-plugin-properties \
157 #  totem-plugin-screensaver \
158 #  totem-plugin-skipto \
159 #  totem-plugin-thumbnail \
160 "
161
162 TOUCHSCREEN = " \
163   gtk-touchscreen-mode-enable \
164   libgtkstylus \
165   xinput-calibrator \
166 "
167
168 XFCE46_BASE = " \
169   xfce4-dev-tools \
170   xfwm4 \
171   xfwm4-theme-default \
172   xfce-utils \  
173   xfce4-session \     
174   xfconf \
175   xfdesktop \
176   xfce4-panel \
177   xfce4-power-manager \
178   \
179   gtk-xfce-engine \
180   \
181   xfce4-panel-plugin-actions \
182   xfce4-panel-plugin-clock \
183   xfce4-panel-plugin-iconbox \
184   xfce4-panel-plugin-launcher \
185   xfce4-panel-plugin-pager \
186   xfce4-panel-plugin-separator \
187   xfce4-panel-plugin-showdesktop \
188   xfce4-panel-plugin-systray \
189   xfce4-panel-plugin-tasklist \
190   xfce4-panel-plugin-windowlist \   
191   xfce4-settings \
192   xfce-terminal \
193   thunar \
194 "
195
196 XFCE46_EXTRAS = " \
197   xfce4-notifyd \
198   xfce4-mixer \
199   xfce4-appfinder \
200   xfce4-battery-plugin \
201   xfprint \    
202   orage \
203   squeeze \
204   ristretto \
205   mousepad \ 
206   gigolo \
207 "
208
209 XFCE_THEMES = " \
210   xfwm4-theme-daloa \
211   xfwm4-theme-moheli \
212 #  xfwm4-theme-default-4.0 \
213 #  xfwm4-theme-default-4.2 \
214 #  xfwm4-theme-default-4.4 \
215   xfwm4-theme-kokodi \
216   xfwm4-theme-sassandra \
217 #  xfwm4-theme-stoneage \
218 #  xfwm4-theme-therapy \
219 #  xfwm4-theme-tyrex \
220 #  xfwm4-theme-wallis \  
221   xfwm4-themes \
222 "
223
224 XSERVER_BASE = " \
225   ${XSERVER} \
226   dbus-x11 \
227   desktop-file-utils \
228   iso-codes \
229   mime-support \
230   notification-daemon inotify-tools \
231   xauth \
232   xdg-utils \
233   xhost \
234   xinetd \
235   xinit \
236   xlsfonts \
237   xrdb \
238   xrefresh \
239   xset \
240   xvinfo \
241   devilspie \
242   encodings \
243   xterm \
244   xmodmap \
245 "
246
247 RDEPENDS_${PN} = " \
248   task-pandora-core \
249   angstrom-x11-base-depends \
250   ${ANGSTROM_EXTRA_INSTALL} \
251   ${APPS} \
252   ${BLUETOOTH_GUI} \
253   ${IM_CLIENT} \
254   ${DISPMAN} \
255   ${FONTS} \
256   ${GAMES} \  
257   ${GNOME_GTK} \
258   ${GNOME_APPS} \
259   ${GSTREAMER} \
260   ${ICON_THEME} \
261   ${LAUNCHERS} \
262   ${PANDORA} \
263   ${PERL} \
264   ${PULSEAUDIO} \
265   ${QT_SUPPORT} \
266   ${TOTEM} \
267   ${TOUCHSCREEN} \
268   ${XSERVER_BASE} \
269   ${XFCE46_BASE} \
270   ${XFCE46_EXTRAS} \
271   ${XFCE_THEMES} \
272   \
273   rxvt-unicode \
274 #  xst \
275 #  suspend-desktop \
276 #  teleport \
277   gdk-pixbuf-loader-png \
278   gdk-pixbuf-loader-xpm \
279   gdk-pixbuf-loader-jpeg \
280   pango-module-basic-x \
281   pango-module-basic-fc \
282   xcursor-transparent-theme \   
283   xterm xmms \
284   jaaa nmap iperf \
285 #  gnuplot \
286 "