task-pandora-xfce: Removed some non-needed qt4 stuff
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r55"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13 #  abiword \
14   evince \
15 #  claws-mail \
16   swfdec swfdec-gnome swfdec-mozilla \
17 #  gnumeric \   
18   networkmanager network-manager-applet \ 
19   vnc x11vnc angstrom-x11vnc-xinit \
20   xchat \
21   links-x11 \
22   enchant \
23   aspell \
24   xwininfo \
25 #  xournal \
26 #  arora \
27 "
28
29 BLUETOOTH_GUI = " \
30   gnome-bluetooth \
31 "
32
33 IM_CLIENT = " \
34 #  pidgin \
35 #  libpurple-protocol-msn \
36 #  libpurple-protocol-yahoo \
37 #  libpurple-protocol-icq \
38 #  libpurple-protocol-aim \
39 "
40
41 DISPMAN = " \
42   slim \
43   slim-op-themes \
44 "
45
46 FONTS = " \
47   font-adobe-75dpi \
48   fontconfig fontconfig-utils font-util \
49   ttf-arphic-uming \
50   ttf-dejavu-common \
51   ttf-dejavu-sans \
52   ttf-dejavu-serif \
53   ttf-dejavu-sans-mono \
54   ttf-liberation-sans \
55   ttf-liberation-serif \
56   ttf-liberation-mono \
57   xorg-minimal-fonts \
58 "  
59
60 # Any default games we want to ship.
61 GAMES = " \
62 #  scummvm \
63 #  frozen-bubble \
64 #  gnome-games \  
65 #  numptyphysics \
66 "
67
68 GNOME_APPS = " \
69 #  gnome-mplayer \
70   gcalctool \ 
71   gnome-keyring gnome-keyring-pam-plugin \
72   gksu \
73 "
74
75 GSTREAMER = " \
76 #  gstreamer-ti \
77   gst-ffmpeg \
78   gst-omapfb \
79 #  gst-plugin-pulse \
80   gst-plugin-xvimagesink \
81   gst-plugins-base-meta \
82 #  gst-plugins-good-meta \
83 #  gst-plugins-bad-meta \
84 #  gst-plugins-ugly-meta \
85   gst-plugin-gles \
86 "
87
88 ICON_THEME = " \
89   hicolor-icon-theme \
90   elementary-icon-theme \
91   elementary-icon-theme-enable \
92 "
93
94 LAUNCHERS = " \
95 #  netbook-launcher-efl \
96   pandora-libpnd-minimenu \
97 #  pandora-pmenu \
98 "
99
100 PANDORA = " \
101   pandora-first-run-wizard hsetroot \
102   pandora-scripts \
103   pandora-wallpaper-official \
104   pandora-xfce-defaults \
105 #  pandora-midori-defaults midori \
106   libgles2d \
107   pandora-misc \
108   pandora-pndstore \
109 "
110
111 PERL = " \
112   perl \
113   task-perl-module-all \
114   libnet-dbus-perl \
115   libxml-parser-perl \
116   libxml-twig-perl \
117 "
118
119 PULSEAUDIO = " \
120 #  pulseaudio-alsa-wrapper \
121 #  pulseaudio-esd-wrapper \
122 #  pulseaudio-module-gconf \
123 #  libasound-module-ctl-pulse \
124 #  libasound-module-pcm-pulse \
125 "
126
127 PYTHON_LIBS = " \
128   python-shell \
129   python-pygtk \
130   python-pycairo \
131   gnome-vfs-plugin-http \
132   gnome-vfs-plugin-ftp \
133 "
134
135 QT_SUPPORT = " \
136  libqt3support4 \ 
137  libqtassistantclient4 \ 
138  libqtclucene4 \ 
139  libqtcore4 \ 
140  libqtdbus4 \ 
141  libqtdesigner4 \ 
142  libqtdesignercomponents4 \ 
143  libqtgui4 \ 
144  libqthelp4 \ 
145  libqtnetwork4 \  
146  libqtscript4 \ 
147  libqtscripttools4 \ 
148  libqtsql4 \ 
149  libqtsvg4 \ 
150  libqttest4 \ 
151  libqtuitools4 \ 
152  libqtwebkit4 \ 
153  libqtxml4 \ 
154  libphonon4 \ 
155  qt4-tools \ 
156  qt4-assistant \ 
157  qt4-common \ 
158  qt4-dbus \ 
159  qt4-designer \ 
160  qt4-fonts \ 
161  qt4-linguist \ 
162  qt4-mkspecs \ 
163  qt4-pixeltool \ 
164  qt4-qt3to4 \
165  qt4-plugin-imageformat-jpeg \
166  qt4-plugin-imageformat-gif \
167 "
168
169
170 TOTEM = " \
171 #  totem \
172 #  totem-browser-plugin \
173 #  totem-plugin-bemused \
174 #  totem-plugin-gromit \
175 #  totem-plugin-media-player-keys \
176 #  totem-plugin-ontop \
177 #  totem-plugin-properties \
178 #  totem-plugin-screensaver \
179 #  totem-plugin-skipto \
180 #  totem-plugin-thumbnail \
181 "
182
183 TOUCHSCREEN = " \
184   gtk-touchscreen-mode-enable \
185   libgtkstylus \
186 #  xinput-calibrator \
187 "
188
189 XFCE46_BASE = " \
190   xfce4-dev-tools \
191   xfwm4 \
192   xfwm4-theme-default \
193   xfce-utils \  
194   xfce4-session \     
195   xfconf \
196   xfdesktop \
197   xfce4-panel \
198   xfce4-power-manager \
199   \
200   gtk-xfce-engine \
201   \
202   xfce4-panel-plugin-actions \
203   xfce4-panel-plugin-clock \
204   xfce4-panel-plugin-iconbox \
205   xfce4-panel-plugin-launcher \
206   xfce4-panel-plugin-pager \
207   xfce4-panel-plugin-separator \
208   xfce4-panel-plugin-showdesktop \
209   xfce4-panel-plugin-systray \
210   xfce4-panel-plugin-tasklist \
211   xfce4-panel-plugin-windowlist \   
212   xfce4-settings \
213   xfce-terminal \
214   thunar \
215 "
216
217 XFCE46_EXTRAS = " \
218   xfce4-notifyd \
219   xfce4-mixer \
220   xfce4-appfinder \
221   xfce4-battery-plugin \
222   xfprint \    
223   orage \
224   squeeze \
225   ristretto \
226   mousepad \ 
227   gigolo \
228   xdotool \
229 "
230
231 XFCE_THEMES = " \
232   xfwm4-theme-daloa \
233   xfwm4-theme-moheli \
234   xfwm4-theme-kokodi \
235   xfwm4-theme-sassandra \
236   xfwm4-themes \
237 "
238
239 XSERVER_BASE = " \
240   ${XSERVER} \
241   dbus-x11 \
242   desktop-file-utils \
243   iso-codes \
244   mime-support \
245   notification-daemon inotify-tools \
246   xauth \
247   xdg-utils \
248   xhost \
249   xinetd \
250   xinit \
251   xlsfonts \
252   xrdb \
253   xrefresh \
254   xset \
255   xvinfo \
256   devilspie \
257   encodings \
258   xterm \
259   xmodmap \
260 "
261
262 ADD_LIBS = " \
263   libbonobo \
264   libetpan \
265   libfribidi \
266   libgsf \
267   libidn \
268   libxslt \
269   wv \
270   libsamplerate0 \
271   glibc-gconv-cp1252 \
272   glibc-gconv-ibm850 \
273   glibc-gconv-iso8859-15 \
274   
275
276
277 RDEPENDS_${PN} = " \
278   task-pandora-core \
279   angstrom-x11-base-depends \
280   ${ANGSTROM_EXTRA_INSTALL} \
281   ${APPS} \
282   ${BLUETOOTH_GUI} \
283   ${IM_CLIENT} \
284   ${DISPMAN} \
285   ${FONTS} \
286   ${GAMES} \  
287   ${GNOME_APPS} \
288   ${GSTREAMER} \
289   ${ICON_THEME} \
290   ${LAUNCHERS} \
291   ${PANDORA} \
292   ${PERL} \
293   ${PULSEAUDIO} \
294   ${PYTHON_LIBS} \
295   ${QT_SUPPORT} \
296   ${TOTEM} \
297   ${TOUCHSCREEN} \
298   ${XSERVER_BASE} \
299   ${XFCE46_BASE} \
300   ${XFCE46_EXTRAS} \
301   ${XFCE_THEMES} \
302   ${ADD_LIBS} \
303   \
304   rxvt-unicode \
305 #  xst \
306 #  suspend-desktop \
307 #  teleport \
308   gdk-pixbuf-loader-png \
309   gdk-pixbuf-loader-xpm \
310   gdk-pixbuf-loader-jpeg \
311   pango-module-basic-x \
312   pango-module-basic-fc \
313   xcursor-transparent-theme \   
314   xterm \
315   jaaa nmap iperf \
316 #  gnuplot \
317 "