task-pandora-xfce: Add new pandora-defaults packages to the image.
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRI-PTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r18"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13   abiword \
14   claws-mail \
15   swfdec swfdec-gnome swfdec-mozilla \
16   firefox \
17   gnumeric \   
18   gimp \
19   networkmanager network-manager-applet \ 
20   synergy \
21   vnc \
22   x11vnc angstrom-x11vnc-xinit \
23   xmms \
24   xterm \
25 "
26
27 BLUETOOTH_GUI = " \
28 #  blueman \
29   gnome-bluetooth \
30 "
31
32 IM_CLIENT = " \
33   pidgin \
34   libpurple-protocol-msn \
35   libpurple-protocol-yahoo \
36   libpurple-protocol-icq \
37   libpurple-protocol-aim \
38 "
39
40 DISPMAN = " \
41   slim \
42   slim-op-themes \
43 "
44
45 FONTS = " \
46   font-adobe-75dpi \
47   fontconfig fontconfig-utils font-util \
48   ttf-arphic-uming \
49   ttf-dejavu-common \
50   ttf-dejavu-sans \
51   ttf-dejavu-serif \
52   ttf-dejavu-sans-mono \
53   ttf-liberation-sans \
54   ttf-liberation-serif \
55   ttf-liberation-mono \
56   xorg-minimal-fonts \
57 "  
58
59 # Any default games we want to ship.
60 GAMES = " \
61   scummvm \
62 "
63
64 GNOME_APPS = " \
65 #  epiphany epiphany-extensions \
66 #  evince \  
67   gnome-games \
68   gnome-mplayer \
69   gcalctool \ 
70   gnome-keyring gnome-keyring-pam-plugin \
71 "
72
73 GNOME_GTK = " \
74 #  hicolor-icon-theme \
75 #  gnome-icon-theme \
76 #  angstrom-gnome-icon-theme-enable \
77 "
78
79 GSTREAMER = " \
80   gst-ffmpeg \
81   gst-omapfb \
82   gst-plugin-pulse \
83   gst-plugins-base-meta \
84 #  gst-plugins-good-meta \
85   gst-plugins-bad-meta \
86 #  gst-plugins-ugly-meta \
87 "
88
89 ICON_THEME = " \
90   elementary-icon-theme \
91   elementary-icon-theme-enable \
92 "
93
94 PANDORA = " \
95   pandora-first-run-wizard hsetroot xtscal \
96   pandora-scripts \
97   pandora-wallpaper-official pandora-wallpaper-community \
98   pandora-xfce-defaults \
99 "
100
101 PERL = " \
102   perl \
103   task-perl-module-all \
104   libnet-dbus-perl \
105   libxml-parser-perl \
106   libxml-twig-perl \
107 "
108
109 PULSEAUDIO = " \
110   pulseaudio-alsa-wrapper \
111   pulseaudio-esd-wrapper \
112   pulseaudio-module-gconf \
113   libasound-module-ctl-pulse \
114   libasound-module-pcm-pulse \
115 "
116
117 QT_SUPPORT = " \
118   qt4-x11-free \
119 #  qt4-x11-free-gles \
120 "
121
122 TOTEM = " \
123   totem \
124   totem-browser-plugin \
125   totem-plugin-bemused \
126   totem-plugin-gromit \
127   totem-plugin-media-player-keys \
128   totem-plugin-ontop \
129   totem-plugin-properties \
130   totem-plugin-screensaver \
131   totem-plugin-skipto \
132   totem-plugin-thumbnail \
133 "
134
135 TOUCHSCREEN = " \
136   xf86-input-tslib \
137   gtk-touchscreen-mode-enable \
138   libgtkstylus \
139 "
140
141 XFCE46_BASE = " \
142   xfce4-dev-tools \
143   xfwm4 \
144   xfwm4-theme-default \
145   xfce-utils \  
146   xfce4-session \     
147   xfconf \
148   xfdesktop \
149   xfce4-panel \
150   \
151   gtk-xfce-engine \
152   \
153   xfce4-panel-plugin-actions \
154   xfce4-panel-plugin-clock \
155   xfce4-panel-plugin-iconbox \
156   xfce4-panel-plugin-launcher \
157   xfce4-panel-plugin-pager \
158   xfce4-panel-plugin-separator \
159   xfce4-panel-plugin-showdesktop \
160   xfce4-panel-plugin-systray \
161   xfce4-panel-plugin-tasklist \
162   xfce4-panel-plugin-windowlist \   
163   xfce4-settings \
164   xfce-terminal \
165   thunar \
166 "
167
168 XFCE46_EXTRAS = " \
169   xfce4-notifyd \
170   xfce4-mixer \
171   xfce4-appfinder \
172   xfprint \    
173   midori \
174   orage \
175   squeeze \
176   ristretto \
177   mousepad \ 
178   gigolo \
179 "
180
181 XFCE_THEMES = " \
182   xfwm4-theme-daloa \
183   xfwm4-theme-moheli \
184   xfwm4-theme-default-4.0 \
185   xfwm4-theme-default-4.2 \
186   xfwm4-theme-default-4.4 \
187   xfwm4-theme-kokodi \
188   xfwm4-theme-moheli \
189   xfwm4-theme-sassandra \
190   xfwm4-theme-stoneage \
191   xfwm4-theme-therapy \
192   xfwm4-theme-tyrex \
193   xfwm4-theme-wallis \  
194 "
195
196 XSERVER_BASE = " \
197   ${XSERVER} \
198   dbus-x11 \
199   desktop-file-utils \
200   iso-codes \
201   mime-support \
202   notification-daemon inotify-tools \
203   xauth \
204   xdg-utils \
205   xhost \
206   xinetd \
207   xinit \
208   xlsfonts \
209   xrdb \
210   xrefresh \
211   xset \
212   xvinfo \
213   devilspie \
214 "
215
216 RDEPENDS_${PN} = " \
217   task-pandora-core \
218   angstrom-x11-base-depends \
219   ${ANGSTROM_EXTRA_INSTALL} \
220   ${APPS} \
221   ${BLUETOOTH_GUI} \
222   ${IM_CLIENT} \
223   ${DISPMAN} \
224   ${FONTS} \
225   ${GAMES} \  
226   ${GNOME_GTK} \
227   ${GNOME_APPS} \
228   ${GSTREAMER} \
229   ${ICON_THEME} \
230   ${PANDORA} \
231   ${PERL} \
232   ${PULSEAUDIO} \
233   ${QT_SUPPORT} \
234   ${TOTEM} \
235   ${TOUCHSCREEN} \
236   ${XSERVER_BASE} \
237   ${XFCE46_BASE} \
238   ${XFCE46_EXTRAS} \
239   ${XFCE_THEMES} \
240   \
241   rxvt-unicode \
242   xst \
243   suspend-desktop \
244   teleport \
245   gdk-pixbuf-loader-png \
246   gdk-pixbuf-loader-xpm \
247   gdk-pixbuf-loader-jpeg \
248   pango-module-basic-x \
249   pango-module-basic-fc \
250   xcursor-transparent-theme \   
251   mime-support \
252   xterm xmms \
253   jaaa nmap iperf gnuplot \
254   x11vnc angstrom-x11vnc-xinit \
255 "