xfce: Add XFCE (4.6.1) based image (WIP!)
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r0.2"
9
10 inherit task 
11
12 # Use the 'Powered by Angstrom' splashscreen for the Pandora default images.
13 # By doing this here we ensure that anyone building a standard Angstom image
14 # rather then one of these has all the Angstrom branding with no Pandora specifics.
15 PREFERRED_PROVIDER_virtual/psplash = "psplash-pandora"
16
17 RDEPENDS_${PN} = "\
18         task-base-extended \
19         task-proper-tools \
20         pandora-firmware \
21         wl1251-modules \
22 #        pandora-wifi pandora-wifi-tools \
23         pandora-libpnd \
24         omap3-deviceid \        
25         omap3-sgx-modules devmem2 libgles-omap3 \
26         sudo \
27         lsof \
28         libsdl-gfx \
29         nfs-utils nfs-utils-client \
30         tslib tslib-tests tslib-calibrate pointercal \
31         bash \
32         bzip2 \
33         psplash \
34         fbgrab fbset fbset-modes \
35         portmap \
36         fuse sshfs-fuse ntfs-3g \
37         file \
38         aufs aufs-tools \
39         socat \
40         strace \
41         python-pygame \
42         ksymoops \
43         kexec-tools \
44         minicom \
45         nano \
46         alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
47         openssh-scp \
48         openssh-ssh \
49         bluez4 \
50         wireless-tools \
51         rdesktop \
52         zip \
53         networkmanager netm-cli \
54         openssh-scp openssh-ssh \
55         mplayer \
56 "
57
58 # Make sure we install all kernel modules with the Pandora images
59 RRECOMMENDS_${PN} += "kernel-modules"
60
61 PACKAGE_ARCH = "${MACHINE_ARCH}"
62 RRECOMMENDS_${PN}_append_armv7a = " omapfbplay"