task-pandora-xfce: Really remove XMMS from the task (I missed the dupe).
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps and libs in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r24"
9
10 inherit task 
11
12 AUFS = " \
13   aufs2-util \
14 "
15
16 BLUETOOTH = " \
17   blueprobe \
18   bluez4 gst-plugin-bluez \
19   libsndfile1 libasound-module-bluez \
20 "
21
22 # Package up the boot scripts and bootchart to help us work to drop the startup time.
23 BOOT = " \
24   pandora-uboot-scripts \
25   bootchart \
26   mtd-utils \
27 "
28
29 WIRELESS = " \
30   pandora-firmware \
31   wl1251-modules \
32 #  pandora-wifi pandora-wifi-tools \
33   wireless-tools \
34   wpa-supplicant \  
35   networkmanager netm-cli \
36 "
37
38 MEDIA_LIBS = " \
39   libmodplug \
40   libsdl-x11 libsdl-mixer libsdl-image \
41   libsdl-gfx libsdl-net libsdl-ttf \
42   libpng libpng12 libpng3 \
43   faad2 \
44   mikmod \
45   speex \  
46   
47 "
48 OPENGLES = " \
49   omap3-sgx-modules devmem2 \
50   libgles-omap3 \
51   libgles-omap3-rawdemos \
52 "
53
54 PAM = " \
55   libpam \
56   libpam-meta \
57 "
58
59 PANDORA_LIBS = " \
60   pandora-libpnd lsof \
61   omap3-deviceid \
62   pandora-skel \
63   pandora-lcd-state \
64 "
65
66 SUDO = " \
67   sudo sudo-enable-wheel-group \ 
68   pandora-sudoers \
69 "
70
71 SSH = " \
72   openssh-scp \
73   openssh-ssh \
74 "
75
76 TOUCHSCREEN = " \
77   tslib tslib-tests tslib-calibrate pointercal \
78 "
79
80 FS_SUPPORT = " \
81 #  nfs-utils \
82   nfs-utils-client \
83   fuse fuse-utils \
84   sshfs-fuse gmailfs curlftpfs \
85   ntfs-3g \
86   squashfs-tools \
87 "
88
89 EXTRA_TOOLS = " \
90   avahi \
91   fbgrab fbset fbset-modes \
92   portmap \
93   file \
94   socat \
95   strace \
96   ksymoops \
97   kexec-tools \
98   zip \        
99   gzip \
100   bash \
101   bzip2 \  
102   minicom \
103   nano \
104   gdb \
105   sessreg \
106 "
107
108 # Add extra util-linux-ng utils to image. 
109 # TODO: Fix util-linux-ng to meta depend on all subpackages.
110 UTIL_LINUX_NG_EXTRAS = " \
111   util-linux-ng-losetup util-linux-ng-mountall \
112   util-linux-ng-swaponoff \
113 "
114   
115 RDEPENDS_${PN} = "\
116   task-base-extended \
117   task-proper-tools \
118   ${AUFS} \
119   ${WIRELESS} \
120   ${BLUETOOTH} \  
121   ${BOOT} \
122   ${MEDIA_LIBS} \
123   ${OPENGLES} \
124   ${PANDORA_LIBS} \
125   ${PAM} \  
126   ${SSH} \
127   ${SUDO} \
128   ${TOUCHSCREEN} \
129   ${FS_SUPPORT} \
130   ${EXTRA_TOOLS} \
131   ${UTIL_LINUX_NG_EXTRAS} \
132 #        packagekit \
133   python-pygame \
134   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
135   rdesktop \
136   \
137 #  angstrom-zeroconf-audio \
138   angstrom-led-config \ 
139 "
140
141 # Make sure we install all kernel modules with the Pandora images
142 RRECOMMENDS_${PN} += "kernel-modules"
143
144 PACKAGE_ARCH = "${MACHINE_ARCH}"