Bump PR of tasks and commit latest versions to GIT.
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r3.3"
9
10 inherit task 
11
12 RDEPENDS_${PN} = "\
13         task-base-extended \
14         task-proper-tools \
15         pandora-firmware \
16         pandora-wifi pandora-wifi-tools \
17         pandora-libpnd \
18         omap3-deviceid \        
19         omap3-sgx-modules devmem2 libgles-omap3 \
20         sudo \
21         lsof \
22         gnome-volume-manager \
23         libwiimote \
24         libsdl-gfx \
25         nfs-utils nfs-utils-client \
26         i2c-tools \
27         tslib tslib-tests tslib-calibrate pointercal \
28         bash \
29         bzip2 \
30         psplash \
31         fbgrab fbset fbset-modes \
32         portmap \
33         fuse sshfs-fuse ntfs-3g \
34         file \
35         aufs aufs-tools \
36         socat \
37         strace \
38         python-pygame \
39         ksymoops \
40         kexec-tools \
41         minicom \
42         nano \
43         alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
44         openssh-scp \
45         openssh-ssh \
46         bluez4 bluez-hcidump bluez-utils \
47         wireless-tools \
48         rdesktop \
49         zip \
50         openssh-scp openssh-ssh \
51         mplayer \
52         networkmanager netm-cli \
53 "
54
55 # Make sure we install all kernel modules with the Pandora images
56 RRECOMMENDS_${PN} += "kernel-modules"
57
58 PACKAGE_ARCH = "${MACHINE_ARCH}"
59 RRECOMMENDS_${PN}_append_armv7a = " omapfbplay"