task-pandora-core: Added two more boost-libs
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps and libs in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r29"
9
10 inherit task 
11
12 AUFS = " \
13   aufs2-util \
14 "
15
16 BLUETOOTH = " \
17   blueprobe \
18   bluez4 gst-plugin-bluez \
19   libsndfile1 libasound-module-bluez \
20 "
21
22 # Package up the boot scripts and bootchart to help us work to drop the startup time.
23 BOOT = " \
24   pandora-uboot-scripts \
25   bootchart \
26   mtd-utils \
27 "
28
29 # Package BOOST libs so people can use them in apps. It will pull in the RRECOMENDS.
30 BOOST = " \
31   boost \
32   boost-python \
33   boost-serialization \
34 "
35
36 WIRELESS = " \
37   pandora-firmware \
38   wl1251-modules \
39 #  pandora-wifi pandora-wifi-tools \
40   wireless-tools \
41   wpa-supplicant \  
42   networkmanager netm-cli \
43 "
44
45 MEDIA_LIBS = " \
46   libmodplug \
47   libsdl-x11 libsdl-mixer libsdl-image \
48   libsdl-gfx libsdl-net libsdl-ttf \
49   libpng libpng12 libpng3 \
50   faad2 \
51   mikmod \
52   speex \  
53   flac \  
54 "
55 OPENGLES = " \
56   omap3-sgx-modules devmem2 \
57   libgles-omap3 \
58   libgles-omap3-rawdemos \
59 "
60
61 PAM = " \
62   libpam \
63   libpam-meta \
64 "
65
66 PANDORA_LIBS = " \
67   pandora-libpnd lsof \
68   omap3-deviceid \
69   pandora-skel \
70   pandora-state \
71 "
72
73 SUDO = " \
74   sudo sudo-enable-wheel-group \ 
75   pandora-sudoers \
76 "
77
78 SSH = " \
79   openssh-scp \
80   openssh-ssh \
81 "
82
83 TOUCHSCREEN = " \
84   tslib tslib-tests tslib-calibrate pointercal \
85 "
86
87 FS_SUPPORT = " \
88 #  nfs-utils \
89   nfs-utils-client \
90   fuse fuse-utils \
91   sshfs-fuse gmailfs curlftpfs \
92   ntfs-3g \
93   squashfs-tools \
94 "
95
96 EXTRA_TOOLS = " \
97   avahi \
98   fbgrab fbset fbset-modes \
99   portmap \
100   file \
101   socat \
102   strace \
103   ksymoops \
104   kexec-tools \
105   zip \        
106   gzip \
107   bash \
108   bzip2 \  
109   minicom \
110   nano \
111   gdb \
112   sessreg \
113   lua5.1 \
114 "
115
116 # Add extra util-linux-ng utils to image. 
117 # TODO: Fix util-linux-ng to meta depend on all subpackages.
118 UTIL_LINUX_NG_EXTRAS = " \
119   util-linux-ng-losetup util-linux-ng-mountall \
120   util-linux-ng-swaponoff \
121 "
122   
123 RDEPENDS_${PN} = "\
124   task-base-extended \
125   task-proper-tools \
126   ${AUFS} \
127   ${BOOST} \
128   ${WIRELESS} \
129   ${BLUETOOTH} \  
130   ${BOOT} \
131   ${MEDIA_LIBS} \
132   ${OPENGLES} \
133   ${PANDORA_LIBS} \
134   ${PAM} \  
135   ${SSH} \
136   ${SUDO} \
137   ${TOUCHSCREEN} \
138   ${FS_SUPPORT} \
139   ${EXTRA_TOOLS} \
140   ${UTIL_LINUX_NG_EXTRAS} \
141 #        packagekit \
142   python-pygame \
143   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
144   rdesktop \
145   \
146 #  angstrom-zeroconf-audio \
147   angstrom-led-config \ 
148 "
149
150 # Make sure we install all kernel modules with the Pandora images
151 RRECOMMENDS_${PN} += "kernel-modules"
152
153 PACKAGE_ARCH = "${MACHINE_ARCH}"