New Script: op_gammamanager.sh - Lets the user load, create and save LCD gamma profiles
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r13"
10
11 SRC_URI = " \
12           file://op_bright.sh \
13           file://op_cpuspeed.sh \
14           file://op_cpuspeed.desktop \          
15           file://op_wifi.sh \
16           file://op_wifi.desktop \          
17           file://op_bluetooth.sh \
18           file://op_bluetooth-check.desktop \
19           file://op_bluetooth.desktop \          
20           file://op_defaultgui.sh \
21           file://op_defaultgui.desktop \
22           file://op_switchgui.sh \
23           file://op_switchgui.desktop \
24           file://startnetbooklauncher \
25           file://startmmenu \          
26           file://op_calibrate.sh \
27           file://op_calibrate.desktop \
28           file://op_datetime.sh \
29           file://op_datetime.desktop \
30           file://op_usermanager.sh \
31           file://op_usermanager.desktop \
32           file://op_gammamanager.sh \
33           file://op_gammamanager.desktop \
34           file://gui.conf \
35           file://gamma.conf \
36 "
37
38 do_install() {
39           install -d ${D}${prefix}/pandora/scripts/
40           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
41           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
42           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
43           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
44           install -m 0755 ${WORKDIR}/op_defaultgui.sh ${D}${prefix}/pandora/scripts/
45           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
46           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
47           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
48           install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
49           install -m 0755 ${WORKDIR}/op_gammamanager.sh ${D}${prefix}/pandora/scripts/
50           
51           install -d ${D}${datadir}/applications/
52           install -m 0644 ${WORKDIR}/op_cpuspeed.desktop ${D}${datadir}/applications/
53           install -m 0644 ${WORKDIR}/op_wifi.desktop ${D}${datadir}/applications/
54           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
55           install -m 0644 ${WORKDIR}/op_defaultgui.desktop ${D}${datadir}/applications/
56           install -m 0644 ${WORKDIR}/op_switchgui.desktop ${D}${datadir}/applications/          
57           install -m 0644 ${WORKDIR}/op_calibrate.desktop ${D}${datadir}/applications/
58           install -m 0644 ${WORKDIR}/op_datetime.desktop ${D}${datadir}/applications/
59           install -m 0644 ${WORKDIR}/op_usermanager.desktop ${D}${datadir}/applications/
60           install -m 0644 ${WORKDIR}/op_gammamanager.desktop ${D}${datadir}/applications/
61           
62           install -d ${D}${sysconfdir}/xdg/autostart/
63           install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
64
65           install -d ${D}${sysconfdir}/pandora/conf/
66           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
67           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
68
69           install -d ${D}${bindir}/
70           install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
71           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
72 }
73
74 PACKAGE_ARCH = "${MACHINE_ARCH}"
75
76 FILES_${PN} += "${prefix} ${datadir}"