Updated recipes for lcd-state and scripts for the new files.
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r15"
10
11 SRC_URI = " \
12           file://op_bright.sh \
13           file://op_cpuspeed.sh \
14           file://op_cpuspeed.desktop \          
15           file://op_wifi.sh \
16           file://op_wifi.desktop \          
17           file://op_bluetooth.sh \
18           file://op_bluetooth-check.desktop \
19           file://op_bluetooth.desktop \          
20           file://op_defaultgui.sh \
21           file://op_defaultgui.desktop \
22           file://op_switchgui.sh \
23           file://op_switchgui.desktop \
24           file://startnetbooklauncher \
25           file://startmmenu \          
26           file://op_calibrate.sh \
27           file://op_calibrate.desktop \
28           file://op_datetime.sh \
29           file://op_datetime.desktop \
30           file://op_usermanager.sh \
31           file://op_usermanager.desktop \
32           file://op_gammamanager.sh \
33           file://op_gammamanager.desktop \
34           file://op_nubmode.sh \
35           file://op_nubmode.desktop \
36           file://gui.conf \
37           file://gamma.conf \
38           file://op_env.sh \
39 "
40
41 do_install() {
42           install -d ${D}${prefix}/pandora/scripts/
43           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
44           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
45           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
46           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
47           install -m 0755 ${WORKDIR}/op_defaultgui.sh ${D}${prefix}/pandora/scripts/
48           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
49           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
50           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
51           install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
52           install -m 0755 ${WORKDIR}/op_gammamanager.sh ${D}${prefix}/pandora/scripts/
53           install -m 0755 ${WORKDIR}/op_nubmode.sh ${D}${prefix}/pandora/scripts/
54           
55           install -d ${D}${datadir}/applications/
56           install -m 0644 ${WORKDIR}/op_bright.desktop ${D}${datadir}/applications/
57           install -m 0644 ${WORKDIR}/op_cpuspeed.desktop ${D}${datadir}/applications/
58           install -m 0644 ${WORKDIR}/op_wifi.desktop ${D}${datadir}/applications/
59           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
60           install -m 0644 ${WORKDIR}/op_defaultgui.desktop ${D}${datadir}/applications/
61           install -m 0644 ${WORKDIR}/op_switchgui.desktop ${D}${datadir}/applications/          
62           install -m 0644 ${WORKDIR}/op_calibrate.desktop ${D}${datadir}/applications/
63           install -m 0644 ${WORKDIR}/op_datetime.desktop ${D}${datadir}/applications/
64           install -m 0644 ${WORKDIR}/op_usermanager.desktop ${D}${datadir}/applications/
65           install -m 0644 ${WORKDIR}/op_gammamanager.desktop ${D}${datadir}/applications/
66           install -m 0644 ${WORKDIR}/op_nubmode.desktop ${D}${datadir}/applications/
67           
68           install -d ${D}${sysconfdir}/xdg/autostart/
69           install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
70
71           install -d ${D}${sysconfdir}/pandora/conf/
72           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
73           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
74         
75           install -d ${D}${sysconfdir}/profile.d/
76           install -m 0755 ${WORKDIR}/op_env.sh {D}${sysconfdir}/profile.d/
77
78           install -d ${D}${bindir}/
79           install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
80           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
81 }
82
83 PACKAGE_ARCH = "${MACHINE_ARCH}"
84
85 FILES_${PN} += "${prefix} ${datadir}"