pandora-scripts: fix echo redirect
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts-wifi.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 RDEPENDS = "pandora-scripts"
7
8 PR = "r3"
9
10 SRC_URI = " \
11           file://op_wifi.sh \
12           file://op_wifi.pnd \  
13           file://nettool.pnd \
14           file://op_bluetooth.sh \
15           file://op_bluetooth_work.sh \
16           file://op_bluetooth-check.desktop \
17           file://op_bluetooth.desktop \          
18 "
19
20 do_install() {
21           install -d ${D}${prefix}/pandora/scripts/
22           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
23           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
24           install -m 0755 ${WORKDIR}/op_bluetooth_work.sh ${D}${prefix}/pandora/scripts/
25
26           install -d ${D}${prefix}/pandora/apps/
27           install -m 0755 ${WORKDIR}/op_wifi.pnd ${D}${prefix}/pandora/apps/
28
29           install -d ${D}${prefix}/pandora/mmenu/
30           install -m 0755 ${WORKDIR}/nettool.pnd ${D}${prefix}/pandora/mmenu/
31           
32           install -d ${D}${datadir}/applications/
33           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
34           
35           install -d ${D}${sysconfdir}/xdg/autostart/
36           install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
37           
38 }
39
40 PACKAGE_ARCH = "${MACHINE_ARCH}"
41
42 FILES_${PN} += "${prefix} ${datadir}"