pandora-firmware: Removed wl1251-nvs.bin (not needed)
[openpandora.oe.git] / recipes / pandora-system / pandora-firmware.bb
1 DESCRIPTION = "Install binary firmware for Bluetooth and WiFi into the image."
2 LICENSE = "proprietary-binary"
3 RRECOMMENDS_${PN} = "kernel-module-firmware-class"
4 PR = "r3"
5
6 SRC_URI = " \
7         file://brf6300.bin \
8         file://wl1251-fw.bin \
9         file://bluetooth-conf \        
10 "
11
12 SUMMARY = "This is required to support the Bluetooth and WiFi modules on the Pandora"
13 S = "${WORKDIR}"
14
15 do_install() {
16         install -d ${D}${base_libdir}/firmware
17         install -m 0644 ${S}/brf6300.bin ${S}/wl1251-fw.bin ${D}${base_libdir}/firmware/
18         install -d ${D}${sysconfdir}/sysconfig
19         install -m 0755 ${S}/bluetooth-conf ${D}${sysconfdir}/sysconfig/bluetooth     
20 }
21
22 PACKAGE_ARCH = "${MACHINE_ARCH}"
23
24 FILES_${PN} += "${base_libdir}/firmware ${sysconfdir}/sysconfig"
25
26 COMPATIBLE_MACHINE = "omap3-pandora"