pandora-pndstore: update to latest
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel2_3.2-pandora.bb
1 DESCRIPTION = "3.2 Linux kernel for the Pandora handheld console"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4 COMPATIBLE_MACHINE = "omap3-pandora"
5 PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7 PR = "r6"
8
9 # we already build 2.6 kernel using OE infrastructure, and
10 # as we don't know how to build another one into the same image
11 # (especially out-of-tree modules), we just package manually prebuilt one
12 SRC_URI = "http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_r6.tar.bz2"
13
14 S = "${WORKDIR}"
15
16 do_install() {
17   cp -a ${S}/boot ${D}/
18   cp -a ${S}/lib ${D}/
19 }
20
21 FILES_${PN} = "boot lib"
22
23 pkg_postinst_${PN} () {
24   # this will cause depmod to be run on next boot
25   rm -f /lib/modules/`uname -r`/modules.dep
26   sync
27
28   if ! grep -q '[[:blank:]]/[[:blank:]]*ubifs' /proc/mounts; then
29     test -e /media/PANDORABOOT/uImage && oldkernel=/media/PANDORABOOT/uImage
30     test -e /media/PANDORABOOT/uImage-3 && oldkernel=/media/PANDORABOOT/uImage-3
31     test -e /media/BOOT/uImage && oldkernel=/media/BOOT/uImage
32     test -e /media/BOOT/uImage-3 && oldkernel=/media/BOOT/uImage-3
33
34     if test -n "$oldkernel"; then
35       cp /boot/uImage-3 $oldkernel
36       msg="Updated kernel has beed copied to ${oldkernel}. \
37 If this location is wrong, copy /boot/uImage-3 to the location \
38 where your kernel is booted from (usually set in boot.txt / autoboot.txt)."
39     else
40       msg="The kernel in /boot/uImage-3 has been updated. You need to \
41 copy it to the location where kernel is booted from (usually set in \
42 boot.txt / autoboot.txt) or the system might not start after reboot."
43     fi
44     sync
45     if test -n "$DISPLAY"; then
46       zenity --info --text "$msg"
47     else
48       echo "=================================="
49       echo "$msg"
50       sleep 5
51     fi
52   fi
53 }
54
55 PACKAGE_STRIP = "no"
56 SRC_URI[md5sum] = "db11aa3d4924e9684a8bf42f1435ba66"
57 SRC_URI[sha256sum] = "0fe632636eb4d100f3f5b33902dd5a12294067f5beb5bb9e43d24c44f0ac7487"