Rename packages to recipes to sync the overlay with mainline oe.dev
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel-wifi_2.6.27-pandora.bb
1 require linux.inc
2
3 DESCRIPTION = "Test WiFi 2.6.27 Linux kernel for the Pandora handheld console"
4 KERNEL_IMAGETYPE = "uImage"
5
6 COMPATIBLE_MACHINE = "omap3-pandora"
7
8 SRCREV = "5f34ff5fc9e4acd56344552dd15ca6aa4c689fc8"
9
10 #PV = "2.6.27-pandora+git${SRCREV}"
11 PR = "r1"
12
13 SRC_URI = " \
14         git://openpandora.org/pandora-kernel.git;protocol=git;branch=test_wifi \
15         file://defconfig \
16         file://no-empty-flash-warnings.patch;patch=1 \
17         file://oprofile-0.9.3.armv7.diff;patch=1 \
18         file://no-cortex-deadlock.patch;patch=1 \
19         file://read_die_ids.patch;patch=1 \
20         file://fix-install.patch;patch=1 \
21         file://musb-dma-iso-in.eml;patch=1 \
22         file://musb-support-high-bandwidth.patch.eml;patch=1 \
23         file://mru-fix-timings.diff;patch=1 \
24         file://mru-fix-display-panning.diff;patch=1 \
25         file://mru-make-dpll4-m4-ck-programmable.diff;patch=1 \
26         file://mru-add-clk-get-parent.diff;patch=1 \
27         file://mru-improve-pixclock-config.diff;patch=1 \
28         file://mru-make-video-timings-selectable.diff;patch=1 \
29         file://mru-enable-overlay-optimalization.diff;patch=1 \
30         file://musb-fix-ISO-in-unlink.diff;patch=1 \
31         file://musb-fix-multiple-bulk-transfers.diff;patch=1 \
32         file://musb-fix-endpoints.diff;patch=1 \
33         file://dvb-fix-dma.diff;patch=1 \
34         file://0001-Removed-resolution-check-that-prevents-scaling-when.patch;patch=1 \
35         file://0001-Implement-downsampling-with-debugs.patch;patch=1 \
36         file://sitecomwl168-support.diff;patch=1 \
37 #       file://pvr/pvr-add.patch;patch=1 \
38         file://pvr/dispc.patch;patch=1 \
39 #       file://pvr/nokia-TI.diff;patch=1 \
40 "
41         
42 S = "${WORKDIR}/git"
43
44 #do_configure_prepend() {
45 #       install -m 0644 ${S}/arch/arm/configs/omap3_pandora_defconfig ${WORKDIR}/defconfig
46 #}