pandora-xfce-image.bb: Updated to Hotfix 7 Alpha 3
[openpandora.oe.git] / recipes / libsdl / libsdl-x11_1.2.14.1.bb
1 DESCRIPTION = "Simple DirectMedia Layer (X11, Framebuffer, +some OMAP support)"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 LICENSE = "LGPL"
5 DEPENDS = "alsa-lib virtual/libgl virtual/libx11 libxext tslib"
6 PROVIDES = "virtual/libsdl"
7 PR = "r3"
8
9 SRCREV = "0f77a259de72b061bd2eac43e88fd8ab59163e39"
10
11 SRC_URI = " \
12   git://notaz.gp2x.de/~notaz/sdl_omap.git;protocol=git;branch=master \
13   file://sdl.m4 \
14 "
15
16 S = "${WORKDIR}/git"
17
18 inherit autotools binconfig pkgconfig
19
20 EXTRA_OECONF = " \
21   --disable-static --disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
22   --enable-file --enable-oss --enable-alsa --disable-esd --disable-arts \
23   --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
24   --disable-mintaudio --disable-nasm --enable-video-x11 --disable-video-dga \
25   --enable-video-fbcon --disable-video-directfb --disable-video-ps2gs \
26   --disable-video-xbios --disable-video-gem --disable-video-dummy \
27   --enable-video-opengl --enable-input-events --enable-pthreads \
28   --disable-video-picogui --disable-video-qtopia --enable-dlopen \
29   --enable-input-tslib --disable-video-ps3 \
30 "
31
32 do_configure_prepend() {
33   sh autogen.sh
34 }
35
36 do_configure() { 
37   oe_runconf
38 }
39
40 do_configure_append () {
41   cd ${S}
42
43   # prevent libtool from linking libs against libstdc++, libgcc, ...
44   cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
45   mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
46
47   # copy new sdl.m4 macrofile to the dir for installing
48   cp ${WORKDIR}/sdl.m4 ${S}/
49 }
50
51 do_stage() {
52   autotools_stage_all           
53   rm ${STAGING_LIBDIR}/libSDL.la
54 }
55
56 FILES_${PN} = "${libdir}/lib*.so.*"
57 FILES_${PN}-dev += "${bindir}/*config"