fusilli-client: update
[openpandora.oe.git] / recipes / fusilli-client / fusilli-client_git.bb
1 DESCRIPTION = "An alternative client for skeezix c4a network"
2 LICENSE = "GPLv3"
3
4 DEPENDS = "virtual/libsdl libsdl-net pandora-libpnd"
5 RDEPENDS = "libsdl-net pandora-libpnd"
6
7 PR = "r2"
8 PR_append = "+gitr${SRCPV}"
9
10 SRC_URI = " \
11   git://github.com/theZiz/fusilli-client.git;protocol=git;branch=master \
12   file://sparrowNet.c \
13   file://sparrowNet.h \
14   file://sparrowDefines.h \
15 "
16
17 SRCREV = "73642236bbce54852e2a40c4b373b96ee6055691"
18
19 S = "${WORKDIR}/git"
20
21 CFLAGS += "-DMOBILE_DEVICE -DPANDORA"
22
23 do_compile() {
24         cp ${WORKDIR}/sparrowNet.c ${S}/
25         cp ${WORKDIR}/sparrowNet.h ${S}/
26         cp ${WORKDIR}/sparrowDefines.h ${S}/
27
28         oe_runmake SPARROW_FOLDER=. LIB= STATIC=sparrowNet.c \
29                 DYNAMIC='${LDFLAGS} -lSDL_net -lSDL -lpnd'
30 }
31
32 do_install() {
33         install -d ${D}${bindir}/
34         install -m 0755 fusilli ${D}${bindir}/
35 }