Initial import of my local openpandora.oe.git Open Embedded overlay to the GIT server...
[openpandora.oe.git] / packages / pandora-system / pandora-firmware.bb
1 DESCRIPTION = "Install binary firmware for Bluetooth and WiFi into the image."
2 SUMMARY = "This is required to support the Bluetooth and WiFi modules on the Pandora"
3 LICENCE = "proprietary-binary"
4
5 COMPATIBLE_MACHINE = "omap3-pandora"
6 PR = "r1"
7
8 PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10 RRECOMMENDS = "kernel-module-firmware-class"
11
12 SRC_URI = "file://brf6300.bin \
13         file://Fw1251r1c.bin \
14 "
15
16 S = "${WORKDIR}"
17
18 FILES_${PN} = "/lib"
19
20 do_install() {
21         install -d ${D}/lib/firmware/
22         install -m 0644 ${S}/brf6300.bin ${S}/Fw1251r1c.bin ${D}/lib/firmware/
23 }