Cleanup part of my local tree to push up to git.openpandora.org. Not taking history...
[openpandora.oe.git] / packages / pandora-system / pandora-firmware.bb
1 DESCRIPTION = "Install binary firmware for Bluetooth and WiFi into the image."
2 LICENSE = "proprietary-binary"
3 RRECOMMENDS_${PN} = "kernel-module-firmware-class"
4 PR = "r4"
5
6 SRC_URI = " \
7         file://brf6300.bin \
8         file://Fw1251r1c.bin \
9 "
10
11 SUMMARY = "This is required to support the Bluetooth and WiFi modules on the Pandora"
12 S = "${WORKDIR}"
13
14 do_install() {
15         install -d ${D}/lib/firmware
16         install -m 0644 ${S}/brf6300.bin ${S}/Fw1251r1c.bin ${D}/lib/firmware/
17 }
18
19 PACKAGE_ARCH = "${MACHINE_ARCH}"
20
21 FILES_${PN} += "/lib/firmware"
22
23 COMPATIBLE_MACHINE = "omap3-pandora"