xfce46: remove checksum name atribute from bbclass
[openembedded.git] / recipes / xfce-base / xfce4-panel_4.6.3.bb
1 # xfce4-panel OE build file
2
3 DESCRIPTION = "Xfce4 Panel"
4 DEPENDS = "virtual/libx11 startup-notification libxfcegui4 libxml2 exo libwnck"
5 SECTION = "x11"
6 PR = "r2"
7
8 inherit xfce46
9
10 SRC_URI[md5sum] = "0b715abb929220f136483ccd7303ff62"
11 SRC_URI[sha256sum] = "4f5e19187ddf9f812303b77479124562079d25c6263674040aba4395c6b2e41c"
12
13 EXTRA_OECONF += " --enable-startup-notification"
14
15 do_stage() {
16     autotools_stage_all
17 }
18
19 do_install() {
20     oe_runmake DESTDIR=${D} install
21 }
22
23 python populate_packages_prepend() {
24         plugin_dir = bb.data.expand('${libdir}/xfce4/panel-plugins/', d)
25         plugin_name = bb.data.expand('${PN}-plugin-%s', d)
26         do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
27                           '${PN} plugin for %s', extra_depends='', prepend=True,
28                           aux_files_pattern=['${datadir}/xfce4/panel-plugins/%s.desktop',
29                                              '${sysconfdir}/xdg/xfce/panel/%s-*',
30                                              '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
31                                              '${bindir}/*%s*'])
32 }
33
34 PACKAGES_DYNAMIC = "${PN}-plugin-*"