xfce46: remove checksum name atribute from bbclass
authorMartin Jansa <Martin.Jansa@gmail.com>
Tue, 1 Jun 2010 12:24:29 +0000 (14:24 +0200)
committerGrazvydas Ignotas <notasas@gmail.com>
Sat, 29 Dec 2012 17:29:17 +0000 (19:29 +0200)
* ie xfce-base/libxfce4util_4.6.1.bb cannot find it's checksums anymore
* commit e3df76459f7710af61d1b51066e0685c822dbe7b introduced
  name=archive in xfce46.bbclass without adding archive name to all
  recipes using xfce46
* I agree that in case someone will need additional SRC_URI item in
  recipe inheriting xfce46 he will have to add it to this bbclass AND
  update all recipes using it.
* Feel free to fix it the other way around if you expect more
  SRC_URIs/recipe.

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
classes/xfce46.bbclass
recipes/xfce-base/xfce4-panel_4.6.3.bb
recipes/xfce-base/xfce4-settings_4.6.4.bb

index 7e3e418..c24dfa4 100644 (file)
@@ -11,7 +11,7 @@ SECTION ?= "x11/xfce"
 
 XFCE_VERSION = ${PV}
 
-SRC_URI = "http://mocha.xfce.org/archive/src/xfce/${PN}/${@'${PV}'[0:3]}/${PN}-${PV}.tar.bz2;name=archive"
+SRC_URI = "http://mocha.xfce.org/archive/src/xfce/${PN}/${@'${PV}'[0:3]}/${PN}-${PV}.tar.bz2"
 
 inherit autotools gtk-icon-cache pkgconfig
 
index 2e8b241..03ab4e8 100644 (file)
@@ -7,8 +7,8 @@ PR = "r2"
 
 inherit xfce46
 
-SRC_URI[archive.md5sum] = "0b715abb929220f136483ccd7303ff62"
-SRC_URI[archive.sha256sum] = "4f5e19187ddf9f812303b77479124562079d25c6263674040aba4395c6b2e41c"
+SRC_URI[md5sum] = "0b715abb929220f136483ccd7303ff62"
+SRC_URI[sha256sum] = "4f5e19187ddf9f812303b77479124562079d25c6263674040aba4395c6b2e41c"
 
 EXTRA_OECONF += " --enable-startup-notification"
 
index 87f9e46..7769797 100644 (file)
@@ -11,8 +11,8 @@ inherit xfce46
 
 SRC_URI += "file://0001-Port-to-libxklavier-5.0-API.patch;patch=1" 
 
-SRC_URI[archive.md5sum] = "04985407e8e5b916c44780314a177e96"
-SRC_URI[archive.sha256sum] = "a5e3f0d959b0d424355414769250473785043c3977446a73b36fa3a5ce44ecdb"
+SRC_URI[md5sum] = "04985407e8e5b916c44780314a177e96"
+SRC_URI[sha256sum] = "a5e3f0d959b0d424355414769250473785043c3977446a73b36fa3a5ce44ecdb"
 
 RDEPENDS_${PN} = "xfconf exo"