Don't inherit siteinfo in base.bbclass
[openembedded.git] / classes / distutils-common-base.bbclass
1 EXTRA_OEMAKE = ""
2
3 export STAGING_INCDIR
4 export STAGING_LIBDIR
5
6 def python_dir(d):
7         import os, bb
8         staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
9         for majmin in "2.6 2.5 2.4 2.3".split():
10                 if os.path.exists( "%s/python%s" % ( staging_incdir, majmin ) ): return "python%s" % majmin
11         if not "python-native" in bb.data.getVar( "DEPENDS", d, 1 ).split():
12                 raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
13         return "INVALID"
14
15 PYTHON_DIR = "${@python_dir(d)}"
16
17 PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc ${PN}"
18
19 FILES_${PN} = "${bindir}/* ${libdir}/* ${libdir}/${PYTHON_DIR}/*"
20
21 FILES_${PN}-dev += "\
22   ${datadir}/pkgconfig \
23   ${libdir}/pkgconfig \
24   ${libdir}/${PYTHON_DIR}/site-packages/*.la \
25 "
26 FILES_${PN}-dbg += "\
27   ${libdir}/${PYTHON_DIR}/site-packages/.debug \
28   ${libdir}/${PYTHON_DIR}/site-packages/*/.debug \
29   ${libdir}/${PYTHON_DIR}/site-packages/*/*/.debug \
30 "