Don't inherit siteinfo in base.bbclass
authorChris Larson <chris_larson@mentor.com>
Tue, 9 Mar 2010 23:54:57 +0000 (16:54 -0700)
committerChris Larson <chris_larson@mentor.com>
Fri, 19 Mar 2010 17:41:54 +0000 (10:41 -0700)
Acked-by: Richard Purdie <rpurdie@linux.intel.com>
Acked-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Signed-off-by: Chris Larson <chris_larson@mentor.com>
13 files changed:
classes/autotools.bbclass
classes/base.bbclass
classes/siteinfo.bbclass
recipes/arm-kernel-shim/arm-kernel-shim_1.5.bb
recipes/espeak/espeak_1.37.bb
recipes/gnash/gnash.inc
recipes/hping/hping2_1.9.9+2.0.0rc3.bb
recipes/linux/ixp4xx-kernel.inc
recipes/linux/linux.inc
recipes/net-snmp/net-snmp.inc
recipes/ogre/ogre-egl_svn.bb
recipes/openssl/openssl.inc
recipes/perl/perl_5.8.8.bb

index c53583b..31d3578 100644 (file)
@@ -28,6 +28,12 @@ DEPENDS_prepend = "${@autotools_dep_prepend(d)}"
 DEPENDS_virtclass-native_prepend = "${@autotools_dep_prepend(d)}"
 DEPENDS_virtclass-nativesdk_prepend = "${@autotools_dep_prepend(d)}"
 
+inherit siteinfo
+
+# Space separated list of shell scripts with variables defined to supply test
+# results for autoconf tests we cannot run at build time.
+export CONFIG_SITE = "${@siteinfo_get_files(d)}"
+
 acpaths = "default"
 EXTRA_AUTORECONF = "--exclude=autopoint"
 
index 09eb709..76f97d8 100644 (file)
@@ -1355,10 +1355,6 @@ def check_app_exists(app, d):
 # Patch handling
 inherit patch
 
-# Configuration data from site files
-# Move to autotools.bbclass?
-inherit siteinfo
-
 EXPORT_FUNCTIONS do_setscene do_clean do_mrproper do_distclean do_fetch do_unpack do_configure do_compile do_install do_package do_populate_pkgs do_rebuild do_fetchall
 
 MIRRORS[func] = "0"
index 93cee4f..d7f2705 100644 (file)
@@ -112,14 +112,6 @@ def siteinfo_get_files(d):
        bb.debug(1, "SITE files " + sitefiles);
        return sitefiles
 
-#
-# Export CONFIG_SITE to the enviroment. The autotools will make use
-# of this to determine where to load in variables from. This is a
-# space seperate list of shell scripts processed in the order listed.
-#
-export CONFIG_SITE = "${@siteinfo_get_files(d)}"
-
-
 def siteinfo_get_endianess(d):
        info = get_siteinfo_list(d)
        if 'endian-little' in info:
@@ -141,5 +133,3 @@ def siteinfo_get_bits(d):
 #
 SITEINFO_ENDIANESS  = "${@siteinfo_get_endianess(d)}"
 SITEINFO_BITS       = "${@siteinfo_get_bits(d)}"
-
-
index 5e2bbb8..591a32f 100644 (file)
@@ -15,6 +15,8 @@ SRC_URI = "ftp://ftp.buici.com/pub/arm/arm-kernel-shim/arm-kernel-shim-${PV}.tar
 
 S = ${WORKDIR}/arm-kernel-shim-${PV}
 
+inherit siteinfo
+
 CMDLINE_CONSOLE = "console=${@bb.data.getVar("KERNEL_CONSOLE",d,1) or "ttyS0"}"
 
 CMDLINE_ROOT_DSMG600 = "root=/dev/mtdblock2 rootfstype=jffs2 rootflags=noatime rw init=/linuxrc"
index 2a5baf2..f465f6f 100644 (file)
@@ -1,4 +1,5 @@
 require espeak.inc
+inherit siteinfo
 
 EXTRA_PHONEMES = '${@base_contains("SITEINFO_ENDIANESS", "be",  "espeak-data (= ${PV})", "", d)}'
 RDEPENDS_${PN} = "portaudio-v19 ${EXTRA_PHONEMES}"
index bad1ae6..159fb41 100644 (file)
@@ -9,7 +9,7 @@ PR = "r6"
 SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gnash/${PV}/gnash-${PV}.tar.bz2 \
           "
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig siteinfo
 
 EXTRA_OECONF = "--enable-gui=gtk \
                 --enable-renderer=cairo \
index 471be84..f8f4bb7 100644 (file)
@@ -14,6 +14,8 @@ SRC_URI = "http://www.hping.org/hping2.0.0-rc3.tar.gz \
           file://hping2_configure.patch;patch=1"
 S = "${WORKDIR}/hping2-rc3"
 
+inherit siteinfo
+
 #
 # We've patched configure to accept byte order and ostype as env
 # variables Pass those values in to stop it trying to figure it out
index 10779c5..6422177 100644 (file)
@@ -153,7 +153,7 @@ SRC_URI += "${IXP4XX_PATCHES}"
 COMPATIBLE_HOST = 'arm.*-linux.*'
 COMPATIBLE_MACHINE = '(ixp4xx|nslu2|fsg3)'
 
-inherit kernel
+inherit kernel siteinfo
 
 ARCH = "arm"
 
index 2da1df8..39d04e1 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Linux Kernel"
 SECTION = "kernel"
 LICENSE = "GPLv2"
 
-inherit kernel
+inherit kernel siteinfo
 
 RPSRC = "http://www.rpsys.net/openzaurus/patches/archive"
 
index 7ba48c6..a96ae70 100644 (file)
@@ -8,7 +8,7 @@ RDEPENDS_${PN}-dev = "net-snmp-client (= ${EXTENDPV}) net-snmp-server (= ${EXTEN
 RRECOMMENDS_${PN}-dbg = "net-snmp-client (= ${EXTENDPV}) net-snmp-server (= ${EXTENDPV})"
 INC_PR = "r5"
 
-inherit autotools update-rc.d
+inherit autotools update-rc.d siteinfo
 
 TARGET_CC_ARCH += "${LDFLAGS}"
 
index 82c7862..abebf9d 100644 (file)
@@ -11,7 +11,7 @@ SRC_URI = "svn://ogre.svn.sourceforge.net/svnroot/ogre;module=trunk;proto=https
            file://ogre-egl-update.diff;patch=1;pnum=0 \
           "
 
-inherit autotools_stage
+inherit autotools_stage siteinfo
 
 # This is the EGL version
 EXTRA_OECONF = " --with-gui=gtk --disable-freetypetest --enable-ogre-demos --with-allocator=std --enable-threading=no --disable-cg --enable-gles "
index a06033b..28e0c92 100644 (file)
@@ -6,6 +6,8 @@ SECTION = "libs/network"
 SRC_URI = "http://www.openssl.org/source/openssl-${PV}.tar.gz;name=src"
 S = "${WORKDIR}/openssl-${PV}"
 
+inherit siteinfo
+
 INC_PR = "r11"
 
 AR_append = " r"
index f084630..2019ea6 100644 (file)
@@ -41,6 +41,8 @@ SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/5.0/perl-5.8.8.tar.gz;name=perl588ta
         file://config.sh-64-le \
         file://config.sh-64-be"
 
+inherit siteinfo
+
 # Where to find the native perl
 HOSTPERL = "${STAGING_BINDIR_NATIVE}/perl${PV}"