task-pandora-xfce*: try to make it work
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
old mode 100755 (executable)
new mode 100644 (file)
index b031489..f59cb1a
@@ -1,16 +1,13 @@
-DESCRIPTION = "Task file for the XFCE Pandora image incl. Wifi"
+require task-pandora-xfce.inc
 
-# Don't forget to bump the PR if you change it.
+# bump PR in task-pandora-xfce.inc if you change this
 
-PR = "r75"
-
-inherit task
-
-ANGSTROM_EXTRA_INSTALL ?= ""
+# this is done this way to not break existing installations
 
 RDEPENDS_${PN} = " \
-  task-pandora-core \
-  task-pandora-xfce-nowifi \
+  ${PANDORA_XFCE} \
+  pandora-firmware \
+  wl1251-modules \
   pandora-scripts-wifi \
   pandora-configtray-wifi \
 "