task-pandora-xfce: Added some more missing libs, removed backdrops,
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index d78128f..dbdbe93 100755 (executable)
@@ -2,7 +2,7 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r36"
+PR = "r42"
 
 inherit task
 
@@ -10,11 +10,11 @@ ANGSTROM_EXTRA_INSTALL ?= ""
 
 APPS = " \
   avahi-ui \
-  abiword \
+#  abiword \
   evince \
-  claws-mail \
+#  claws-mail \
   swfdec swfdec-gnome swfdec-mozilla \
-  gnumeric \   
+#  gnumeric \   
   networkmanager network-manager-applet \ 
   vnc x11vnc angstrom-x11vnc-xinit \
   xchat \
@@ -27,11 +27,11 @@ BLUETOOTH_GUI = " \
 "
 
 IM_CLIENT = " \
-  pidgin \
-  libpurple-protocol-msn \
-  libpurple-protocol-yahoo \
-  libpurple-protocol-icq \
-  libpurple-protocol-aim \
+#  pidgin \
+#  libpurple-protocol-msn \
+#  libpurple-protocol-yahoo \
+#  libpurple-protocol-icq \
+#  libpurple-protocol-aim \
 "
 
 DISPMAN = " \
@@ -63,7 +63,7 @@ GAMES = " \
 
 GNOME_APPS = " \
 #  gnome-mplayer \
-#  gcalctool \ 
+  gcalctool \ 
   gnome-keyring gnome-keyring-pam-plugin \
   gksu \
 "
@@ -88,7 +88,7 @@ ICON_THEME = " \
 "
 
 LAUNCHERS = " \
-  netbook-launcher-efl \
+#  netbook-launcher-efl \
   pandora-libpnd-minimenu \
   pandora-pmenu \
 "
@@ -96,7 +96,7 @@ LAUNCHERS = " \
 PANDORA = " \
   pandora-first-run-wizard hsetroot \
   pandora-scripts \
-  pandora-wallpaper-official pandora-wallpaper-community \
+  pandora-wallpaper-official \
   pandora-xfce-defaults \
   pandora-midori-defaults midori \
   libgles2d \
@@ -204,6 +204,7 @@ XFCE46_EXTRAS = " \
   ristretto \
   mousepad \ 
   gigolo \
+  xdotool \
 "
 
 XFCE_THEMES = " \
@@ -237,6 +238,20 @@ XSERVER_BASE = " \
   xmodmap \
 "
 
+ADD_LIBS = " \
+  libbonobo \
+  libetpan \
+  libfribidi \
+  libgsf \
+  libidn \
+  wv \
+  libsamplerate0 \
+  glibc-gconv-cp1252 \
+  glibc-gconv-ibm850 \
+  glibc-gconv-iso8859-15 \
+  
+" 
+
 RDEPENDS_${PN} = " \
   task-pandora-core \
   angstrom-x11-base-depends \
@@ -262,6 +277,7 @@ RDEPENDS_${PN} = " \
   ${XFCE46_BASE} \
   ${XFCE46_EXTRAS} \
   ${XFCE_THEMES} \
+  ${ADD_LIBS} \
   \
   rxvt-unicode \
 #  xst \