task-pandora: Sync in local changes to bump PR's and add more libs to the toolchain.
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
index a8b9815..d78128f 100755 (executable)
@@ -2,7 +2,7 @@ DESCRIPTION = "Task file for the XFCE Pandora image"
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r28"
+PR = "r36"
 
 inherit task
 
@@ -11,13 +11,11 @@ ANGSTROM_EXTRA_INSTALL ?= ""
 APPS = " \
   avahi-ui \
   abiword \
+  evince \
   claws-mail \
   swfdec swfdec-gnome swfdec-mozilla \
-#  firefox \
   gnumeric \   
-#  gimp \
   networkmanager network-manager-applet \ 
-#  synergy \
   vnc x11vnc angstrom-x11vnc-xinit \
   xchat \
 #  xournal \
@@ -70,18 +68,13 @@ GNOME_APPS = " \
   gksu \
 "
 
-GNOME_GTK = " \
-#  gnome-icon-theme \
-#  angstrom-gnome-icon-theme-enable \
-"
-
 GSTREAMER = " \
 #  gstreamer-ti \
-#  gst-ffmpeg \
+  gst-ffmpeg \
   gst-omapfb \
 #  gst-plugin-pulse \
   gst-plugin-xvimagesink \
-#  gst-plugins-base-meta \
+  gst-plugins-base-meta \
 #  gst-plugins-good-meta \
 #  gst-plugins-bad-meta \
 #  gst-plugins-ugly-meta \
@@ -95,7 +88,7 @@ ICON_THEME = " \
 "
 
 LAUNCHERS = " \
-#  netbook-launcher-efl \
+  netbook-launcher-efl \
   pandora-libpnd-minimenu \
   pandora-pmenu \
 "
@@ -126,6 +119,14 @@ PULSEAUDIO = " \
 #  libasound-module-pcm-pulse \
 "
 
+PYTHON_LIBS = " \
+  python-shell \
+  python-pygtk \
+  python-pycairo \
+  gnome-vfs-plugin-http \
+  gnome-vfs-plugin-ftp \
+"
+
 QT_SELECTED = " qt4-x11-free \
 "
 # qt4-x11-free"
@@ -246,7 +247,6 @@ RDEPENDS_${PN} = " \
   ${DISPMAN} \
   ${FONTS} \
   ${GAMES} \  
-  ${GNOME_GTK} \
   ${GNOME_APPS} \
   ${GSTREAMER} \
   ${ICON_THEME} \
@@ -254,6 +254,7 @@ RDEPENDS_${PN} = " \
   ${PANDORA} \
   ${PERL} \
   ${PULSEAUDIO} \
+  ${PYTHON_LIBS} \
   ${QT_SUPPORT} \
   ${TOTEM} \
   ${TOUCHSCREEN} \