task-pandora-xfce: Really remove XMMS from the task (I missed the dupe).
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
index 24956cc..8d2dfe9 100755 (executable)
@@ -5,12 +5,11 @@ DESCRIPTION = "Task file for default core/console apps and libs in the Pandora i
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r13"
+PR = "r24"
 
 inherit task 
 
 AUFS = " \
-#  aufs2-27 \
   aufs2-util \
 "
 
@@ -24,6 +23,7 @@ BLUETOOTH = " \
 BOOT = " \
   pandora-uboot-scripts \
   bootchart \
+  mtd-utils \
 "
 
 WIRELESS = " \
@@ -32,13 +32,15 @@ WIRELESS = " \
 #  pandora-wifi pandora-wifi-tools \
   wireless-tools \
   wpa-supplicant \  
-  networkmanager netm-cli \  
+  networkmanager netm-cli \
 "
 
 MEDIA_LIBS = " \
   libmodplug \
   libsdl-x11 libsdl-mixer libsdl-image \
   libsdl-gfx libsdl-net libsdl-ttf \
+  libpng libpng12 libpng3 \
+  faad2 \
   mikmod \
   speex \  
   
@@ -46,7 +48,7 @@ MEDIA_LIBS = " \
 OPENGLES = " \
   omap3-sgx-modules devmem2 \
   libgles-omap3 \
-#  libgles-omap3-demos \
+  libgles-omap3-rawdemos \
 "
 
 PAM = " \
@@ -58,6 +60,7 @@ PANDORA_LIBS = " \
   pandora-libpnd lsof \
   omap3-deviceid \
   pandora-skel \
+  pandora-lcd-state \
 "
 
 SUDO = " \
@@ -119,6 +122,7 @@ RDEPENDS_${PN} = "\
   ${MEDIA_LIBS} \
   ${OPENGLES} \
   ${PANDORA_LIBS} \
+  ${PAM} \  
   ${SSH} \
   ${SUDO} \
   ${TOUCHSCREEN} \
@@ -129,20 +133,12 @@ RDEPENDS_${PN} = "\
   python-pygame \
   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
   rdesktop \
-  mplayer \
   \
 #  angstrom-zeroconf-audio \
   angstrom-led-config \ 
-  \
-  ${PAM} \
 "
 
 # Make sure we install all kernel modules with the Pandora images
 RRECOMMENDS_${PN} += "kernel-modules"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-RRECOMMENDS_${PN}_append_armv7a = " \
-#      gnash gnash-browser-plugin \
-       omapfbplay \
-"