task-pandora-core: Added two more boost-libs
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
index 8d2dfe9..1ce683b 100755 (executable)
@@ -5,7 +5,7 @@ DESCRIPTION = "Task file for default core/console apps and libs in the Pandora i
 
 # Don't forget to bump the PR if you change it.
 
-PR = "r24"
+PR = "r29"
 
 inherit task 
 
@@ -26,6 +26,13 @@ BOOT = " \
   mtd-utils \
 "
 
+# Package BOOST libs so people can use them in apps. It will pull in the RRECOMENDS.
+BOOST = " \
+  boost \
+  boost-python \
+  boost-serialization \
+"
+
 WIRELESS = " \
   pandora-firmware \
   wl1251-modules \
@@ -43,7 +50,7 @@ MEDIA_LIBS = " \
   faad2 \
   mikmod \
   speex \  
-  
+  flac \  
 "
 OPENGLES = " \
   omap3-sgx-modules devmem2 \
@@ -60,7 +67,7 @@ PANDORA_LIBS = " \
   pandora-libpnd lsof \
   omap3-deviceid \
   pandora-skel \
-  pandora-lcd-state \
+  pandora-state \
 "
 
 SUDO = " \
@@ -103,6 +110,7 @@ EXTRA_TOOLS = " \
   nano \
   gdb \
   sessreg \
+  lua5.1 \
 "
 
 # Add extra util-linux-ng utils to image. 
@@ -116,6 +124,7 @@ RDEPENDS_${PN} = "\
   task-base-extended \
   task-proper-tools \
   ${AUFS} \
+  ${BOOST} \
   ${WIRELESS} \
   ${BLUETOOTH} \  
   ${BOOT} \