pandora-scripts: allow to configure idle power LED brightness
[openpandora.oe.git] / recipes / pandora-system / pandora-version.bb
index def1dcd..1256a9e 100644 (file)
@@ -1,16 +1,21 @@
 DESCRIPTION = "Installs /etc/op-version file."
 LICENSE = "Public Domain"
-PR = "r3"
+PR = "r26"
 
 do_install() {
   OLD_PWD=$PWD
-  opvf=${D}/${sysconfdir}/op-version
   cd `dirname "${FILE_DIRNAME}"`
+  tag=`git describe --abbrev=0`
+  commits=`git log --oneline ${tag}..HEAD | wc -l`
+  updv=""
+  test "$commits" = "0" || updv=" update $commits"
   install -d ${D}${sysconfdir}/
+  opvf=${D}/${sysconfdir}/op-version
   echo "Tag Name: `git describe`" > ${opvf}
   echo "GIT-VERSION: `git log -n1 --pretty=oneline|awk '{print $1}'`" >> ${opvf}
   echo "Branch: `git branch | awk '/*/{print $2}'`" >> ${opvf}
-  echo "Version: 1.9.1.1 - R1.62 RC Codename Super Zaxxon" >> ${opvf}
+  echo "Version: 1.9.7.4 - R1.74 Codename Super Zaxxon" >> ${opvf}
+  echo "Display Ver: SuperZaxxon 1.74${updv}" >> ${opvf}
   echo "Image Builder: ${LOGNAME}@`cat /etc/hostname`" >> ${opvf}
   echo "Time Stamp: `date -R`" >> ${opvf}
 }