pandora-skel.bb: Added Desktop-Directory into skel (this fixes permissions of Desktop...
[openpandora.oe.git] / recipes / pandora-system / pandora-skel.bb
index b1c0d38..1a322c8 100644 (file)
@@ -5,7 +5,7 @@ COMPATIBLE_MACHINE = "omap3-pandora"
 # /etc/skel is used by Shadow's useradd so you really have that installed for this to make sense ;)
 RDEPENDS = "shadow"
 
-PR = "r1"
+PR = "r6"
 
 SRC_URI = " \
   file://.xinitrc \     
@@ -16,6 +16,7 @@ SRC_URI = " \
   file://xsettings.xml \
   file://pndXmodmap \
   file://asoundrc \
+  file://vimrc \
 #  file://op_btenabled \
 "
 
@@ -23,7 +24,9 @@ SRC_URI = " \
 
 do_install() {
   install -d ${D}${sysconfdir}/skel/
+  install -d ${D}${sysconfdir}/skel/Desktop
   install -m 0644 ${WORKDIR}/.xinitrc ${D}${sysconfdir}/skel/.xinitrc
+  install -m 0644 ${WORKDIR}/vimrc ${D}${sysconfdir}/skel/.vimrc
   install -m 0644 ${WORKDIR}/bashrc ${D}${sysconfdir}/skel/.bashrc
   install -m 0644 ${WORKDIR}/profile ${D}${sysconfdir}/skel/.profile
   install -m 0644 ${WORKDIR}/pam_environment ${D}${sysconfdir}/skel/.pam_environment