pandora-skel: Add script that automatically does ntpdate whenever NetworkManager...
[openpandora.oe.git] / recipes / pandora-system / pandora-skel.bb
index 3b85dca..d0d4030 100644 (file)
@@ -5,7 +5,7 @@ COMPATIBLE_MACHINE = "omap3-pandora"
 # /etc/skel is used by Shadow's useradd so you really have that installed for this to make sense ;)
 RDEPENDS = "shadow"
 
-PR = "r22"
+PR = "r23"
 
 SRC_URI = " \
   file://.xinitrc \     
@@ -32,6 +32,9 @@ do_install() {
   install -d ${D}${sysconfdir}/skel/Desktop
   install -d ${D}${sysconfdir}/modutils/
   install -d ${D}${sysconfdir}/pandora/
+  install -d ${D}${sysconfdir}/NetworkManager/
+  install -d ${D}${sysconfdir}/NetworkManager/dispatcher.d/
+  install -m 0755 ${WORKDIR}/ntpdate.sh  ${D}${sysconfdir}/NetworkManager/dispatcher.d/ntpdate.sh
   install -m 0644 ${WORKDIR}/.xinitrc ${D}${sysconfdir}/skel/.xinitrc
   install -m 0644 ${WORKDIR}/vimrc ${D}${sysconfdir}/skel/.vimrc
   install -m 0644 ${WORKDIR}/bashrc ${D}${sysconfdir}/skel/.bashrc