pandora-scripts: mark conffiles so they are kept on update
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
index 7ab1bdb..fe0feb2 100644 (file)
@@ -6,7 +6,7 @@ COMPATIBLE_MACHINE = "omap3-pandora"
 DEPENDS = "zenity dbus"
 RDEPENDS = "zenity dbus"
 
-PR = "r110"
+PR = "r126"
 
 SRC_URI = " \
           file://op_paths.sh \
@@ -14,8 +14,12 @@ SRC_URI = " \
           file://op_cpuspeed.sh \
           file://op_cpuspeed.pnd \     
          file://op_usbhost.sh \
-          file://op_usbhost.pnd \     
+          file://op_usbhost.pnd \
+          file://op_osupgrade.sh \
+          file://op_osupgrade.pnd \
           file://op_sysspeed.sh \
+         file://op_createsd.sh \
+         file://op_createsd.pnd \
           file://op_wifi.sh \
           file://op_wifi.pnd \  
           file://op_bluetooth.sh \
@@ -84,13 +88,17 @@ SRC_URI = " \
          file://op_bright_up.sh \  
          file://op_menu.sh \ 
          file://op_xfcemenu.sh \
+         file://op_hugetlb.sh \
+         file://op_gamma.sh \
 "
 
 do_install() {
           install -d ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_paths.sh ${D}${prefix}/pandora/scripts/
+         install -m 0755 ${WORKDIR}/op_osupgrade.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_createsd.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_sysspeed.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
@@ -117,6 +125,8 @@ do_install() {
          install -m 0755 ${WORKDIR}/op_bright_up.sh ${D}${prefix}/pandora/scripts/  
          install -m 0755 ${WORKDIR}/op_menu.sh ${D}${prefix}/pandora/scripts/ 
          install -m 0755 ${WORKDIR}/op_xfcemenu.sh ${D}${prefix}/pandora/scripts/ 
+         install -m 0755 ${WORKDIR}/op_hugetlb.sh ${D}${prefix}/pandora/scripts/
+         install -m 0755 ${WORKDIR}/op_gamma.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/reset_nubs.sh ${D}${prefix}/pandora/scripts/ 
          install -m 0644 ${WORKDIR}/pndlogo.png ${D}${prefix}/pandora/scripts/ 
          install -m 0755 ${WORKDIR}/ConfigModel.py ${D}${prefix}/pandora/scripts/
@@ -130,6 +140,7 @@ do_install() {
 
           install -d ${D}${prefix}/pandora/apps/
           install -m 0755 ${WORKDIR}/op_calibrate.pnd ${D}${prefix}/pandora/apps/
+          install -m 0755 ${WORKDIR}/op_createsd.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_cpuspeed.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_datetime.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_lcdsettings.pnd ${D}${prefix}/pandora/apps/
@@ -144,6 +155,7 @@ do_install() {
           install -m 0755 ${WORKDIR}/op_tvout.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_inputtest.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_lidsettings.pnd ${D}${prefix}/pandora/apps/
+         install -m 0755 ${WORKDIR}/op_osupgrade.pnd ${D}${prefix}/pandora/apps/
 
          install -d ${D}${prefix}/pandora/mmenu/
           install -m 0755 ${WORKDIR}/evince.pnd ${D}${prefix}/pandora/mmenu/
@@ -186,3 +198,10 @@ do_install() {
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 FILES_${PN} += "${prefix} ${datadir}"
+
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gui.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/cpu.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gamma.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/service.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/nub_profiles.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/tvout-profiles.conf