pandora-scripts: Update helper scripts.
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
index 9d5d659..51b8ae7 100644 (file)
@@ -3,18 +3,24 @@ LICENSE = "GPLV2"
 
 COMPATIBLE_MACHINE = "omap3-pandora"
 
-PR = "r0"
+PR = "r3"
 
 SRC_URI = " \
           file://op_bright.sh \
           file://op_bright.desktop \
+          file://op_cpuspeed.sh \
+          file://op_cpuspeed.desktop \          
 "
 
 do_install() {
           install -d ${D}${prefix}/pandora/scripts/
-          install -m 0755 ${S}/op_bright.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/          
           install -d ${D}${datadir}/applications/
-          install -m 0644 ${S}/op_bright.desktop ${D}${datadir}/applications/
+          install -m 0644 ${WORKDIR}/op_bright.desktop ${D}${datadir}/applications/
+          install -m 0644 ${WORKDIR}/op_cpuspeed.desktop ${D}${datadir}/applications/          
 }
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+FILES_${PN} += "${prefix} ${datadir}"
\ No newline at end of file