pandora-pndstore.bb: Updated to latest version
[openpandora.oe.git] / recipes / pandora-system / pandora-pndstore.bb
index 1786b14..fb538bc 100755 (executable)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Download and upgrade PND packages."
 LICENSE = "LGPL"
 
-PR = "r6"
+PR = "r9"
 
 SRC_URI = " \
           git://github.com/Tempel/PNDstore.git;protocol=git;branch=master \
@@ -9,17 +9,17 @@ SRC_URI = " \
           file://op_pndstore.desktop \
 "
 
-SRCREV = "8bbc5ef07280e2e26e11"
+SRCREV = "327d095b1497d5fc68552a18f1b04bde0da00a13"
 
 S = "${WORKDIR}/git"
 
-do_install() {
+inherit distutils
 
-      python setup.py install --root=${D}
+do_install_append() {
 
       # A stop-gap fix to the ctypes bug.
       # This can be removed once the python-ctypes package is made to behave correctly.
-      install -m 0644 ${WORKDIR}/_ctypes.so ${D}/usr/lib/python2.6/lib-dynload/_ctypes.so
+      install -Dm 0644 ${WORKDIR}/_ctypes.so ${D}/usr/lib/python2.6/lib-dynload/_ctypes.so
         
       install -Dm 0644 ${WORKDIR}/op_pndstore.desktop ${D}${datadir}/applications/op_pndstore.desktop 
       install -Dm 0644 ${S}/resources/icon.png ${D}${datadir}/pixmaps/op_pndstore.png
@@ -28,4 +28,4 @@ do_install() {
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-FILES_${PN} += "${prefix} ${datadir}"
\ No newline at end of file
+FILES_${PN} += "${prefix} ${datadir}"