task-pandora-*: Commit latest Xfce and Core tasks to build PAM correctly and package...
[openpandora.oe.git] / recipes / pandora-system / pandora-matchbox-gtk-theme.bb
index 97b7ad2..ec89057 100755 (executable)
@@ -3,18 +3,35 @@ LICENSE = "GPL"
 DEPENDS = "matchbox-wm"
 SECTION = "x11/wm"
 
-DEFAULT_PREFERENCE = "-1"
-
 PV = "0.1"
-PR = "r0"
+PR = "r1.2"
 
 PACKAGE_ARCH = "all"
 
-SRC_URI = "svn://svn.o-hand.com/repos/sato/trunk;module=matchbox-sato;proto=http"
-S = "${WORKDIR}/matchbox-sato"
+#GIT HEAD
+SRCREV = 1bd11ea0a6bacafe216bbb29492e064fc52979b0
+
+SRC_URI = " \
+       git://git.openpandora.org/pandora-libraries.git;protocol=git;branch=master \
+"
 
-inherit autotools pkgconfig
+S = "${WORKDIR}/git/gui_theme"
 
-FILES_${PN} = "${datadir}/themes/Sato"
+do_install() {
+       find ${WORKDIR} -name ".git" | xargs rm -rf
+       install -d ${D}${datadir}/themes/pandora-standard/gtk-2.0
+       cp -fpPR ${S}/* ${D}${datadir}/themes/pandora-standard/
+       rm -rf ${D}${datadir}/themes/pandora-standard/patches/
+       
+       install -d ${D}${sysconfdir}/gtk-2.0
+}
 
+#CONFFILES_${PN} = "${sysconfdir}/gtk-2.0/gtkrc"
 
+pkg_postinst() {
+#!/bin/sh
+echo 'include "${datadir}/themes/pandora-standard/gtk-2.0/gtkrc"' >> ${D}${sysconfdir}/gtk-2.0/gtkrc
+}
+
+PACKAGE_ARCH = "all"
+FILES_${PN} = "${datadir} ${sysconfdir}"