pandora-first-run-wizard: Update script to add a background to the X window.
[openpandora.oe.git] / recipes / pandora-system / pandora-first-run-wizard.bb
index 2accf6e..d2a9adb 100755 (executable)
@@ -1,22 +1,33 @@
 DESCRIPTION = "Scripts to support the first run wizard on the OpenPandora."
 LICENSE = "GPLV2"
-RDEPENDS = "pandora-auto-startx zenity dbus"
-
-# Based on the scripts by JohnX/Mer Project - http://wiki.maemo.org/Mer/
+RDEPENDS = "hsetroot zenity dbus"
 
 COMPATIBLE_MACHINE = "omap3-pandora"
 
-PR = "r0.3"
+PR = "r2"
 
 SRC_URI = " \
-          file://first-boot-wizard.sh \
+          file://first-run-wizard.sh \
+          file://rc.firstrun \
+          file://op_default.png \          
 "
 
+inherit update-rc.d
+
+INITSCRIPT_NAME = "oprun-init"
+INITSCRIPT_PARAMS = "start 29 2 3 4 5 . stop  29 2 3 4 5 ."
+
 do_install() {         
-          install -d ${D}${sbindir}
-          cp -pP ${WORKDIR}/first-boot-wizard.sh ${D}${sbindir}/first-boot-wizard.sh
+          install -d ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/first-run-wizard.sh ${D}${prefix}/pandora/scripts/
+          
+          install -d ${D}${sysconfdir}/init.d/
+          install -m 0755 ${WORKDIR}/rc.firstrun ${D}${sysconfdir}/init.d/oprun-init
+          
+          install -d ${D}${datadir}/backgrounds/
+          install -m 0644 ${WORKDIR}/op_default.png ${D}${datadir}/backgrounds/
 }
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-FILES_${PN} += "/lib/firmware"
+FILES_${PN} += "${prefix} ${sysconfdir}"