pandora-firmware: add DSP blob
[openpandora.oe.git] / recipes / pandora-system / pandora-firmware.bb
index 212238d..17d957a 100755 (executable)
@@ -1,15 +1,17 @@
-DESCRIPTION = "Install binary firmware for Bluetooth and WiFi into the image."
+DESCRIPTION = "Binary firmware blobs for WiFi, Bluetooth and DSP."
+SUMMARY = "This is required to support WiFi, BT and DSP on the Pandora"
 LICENSE = "proprietary-binary"
-RRECOMMENDS_${PN} = "kernel-module-firmware-class"
-PR = "r3"
+PR = "r5"
 
 SRC_URI = " \
         file://brf6300.bin \
         file://wl1251-fw.bin \
-        file://bluetooth-conf \        
+        file://bluetooth-conf \
+        file://baseimage.dof \
+        file://baseimage.dof.license.txt \
+        file://dspbridge.rules \
 "
 
-SUMMARY = "This is required to support the Bluetooth and WiFi modules on the Pandora"
 S = "${WORKDIR}"
 
 do_install() {
@@ -17,10 +19,16 @@ do_install() {
         install -m 0644 ${S}/brf6300.bin ${S}/wl1251-fw.bin ${D}${base_libdir}/firmware/
         install -d ${D}${sysconfdir}/sysconfig
         install -m 0755 ${S}/bluetooth-conf ${D}${sysconfdir}/sysconfig/bluetooth     
+        install -d ${D}${base_libdir}/dsp
+        install -m 0644 ${S}/baseimage.dof ${D}${base_libdir}/dsp/
+        install -m 0644 ${S}/baseimage.dof.license.txt ${D}${base_libdir}/dsp/
+        install -d ${D}${base_libdir}/udev/rules.d/
+        install -m 0755 ${S}/dspbridge.rules ${D}${base_libdir}/udev/rules.d/
 }
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-FILES_${PN} += "${base_libdir}/firmware ${sysconfdir}/sysconfig"
+FILES_${PN} += "${base_libdir}/firmware ${base_libdir}/dsp \
+               ${sysconfdir}/sysconfig ${base_libdir}/udev/rules.d"
 
 COMPATIBLE_MACHINE = "omap3-pandora"