omap3-pandora-kernel: Rebase patches for latest GIT head.
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel_2.6.27-pandora.bb
index a5b93b3..f41924c 100755 (executable)
@@ -5,40 +5,63 @@ KERNEL_IMAGETYPE = "uImage"
 
 COMPATIBLE_MACHINE = "omap3-pandora"
 
-#GIT HEAD
-SRCREV = "462fa3321de7a3b8646c195130600af296b5e117"
+SRCREV = "abd422d7c820719eb12123ba08fab925e6f9b40c"
+
+SRC_URI = " \
+           git://git.openpandora.org/pandora-kernel.git;protocol=git;branch=pandora-27-omap1 \
+"          
+
+# -------------------------------
 
 PV = "2.6.27-pandora+${PR}+git${SRCREV}"
-PR = "r1.8"
 
-SRC_URI = " \
-       git://openpandora.org/pandora-kernel.git;protocol=git;branch=pandora-27-omap1 \
-       file://defconfig \
-       file://0001-Add-EHCI-patch-suggested-by-Steven-Kipisz.patch;patch=1 \
-       file://0002-Add-missing-define-to-EHCI-OMAP.c.patch;patch=1 \
-       file://no-empty-flash-warnings.patch;patch=1 \
-       file://oprofile-0.9.3.armv7.diff;patch=1 \
-       file://no-cortex-deadlock.patch;patch=1 \
-       file://read_die_ids.patch;patch=1 \
-       file://fix-install.patch;patch=1 \
-       file://musb-dma-iso-in.eml;patch=1 \
-       file://musb-support-high-bandwidth.patch.eml;patch=1 \
-       file://mru-fix-timings.diff;patch=1 \
-       file://mru-fix-display-panning.diff;patch=1 \
-       file://mru-make-dpll4-m4-ck-programmable.diff;patch=1 \
-       file://mru-improve-pixclock-config.diff;patch=1 \
-       file://mru-make-video-timings-selectable.diff;patch=1 \
-       file://mru-enable-overlay-optimalization.diff;patch=1 \
-       file://musb-fix-ISO-in-unlink.diff;patch=1 \
-       file://musb-fix-multiple-bulk-transfers.diff;patch=1 \
-       file://musb-fix-endpoints.diff;patch=1 \
-       file://dvb-fix-dma.diff;patch=1 \
-       file://0001-Removed-resolution-check-that-prevents-scaling-when.patch;patch=1 \
-       file://0001-Implement-downsampling-with-debugs.patch;patch=1 \
-       file://sitecomwl168-support.diff;patch=1 \
-#      file://pvr/pvr-add.patch;patch=1 \
-       file://pvr/dispc.patch;patch=1 \
-#      file://pvr/nokia-TI.diff;patch=1 \
+SRC_URI_append = " \
+           file://defconfig \
+           file://0001-Add-EHCI-patch-suggested-by-Steven-Kipisz.patch;patch=1 \
+           file://0002-Add-missing-define-to-EHCI-OMAP.c.patch;patch=1 \
+           file://no-empty-flash-warnings.patch;patch=1 \
+           file://oprofile-0.9.3.armv7.diff;patch=1 \
+           file://no-cortex-deadlock.patch;patch=1 \
+           file://read_die_ids.patch;patch=1 \
+           file://fix-install.patch;patch=1 \
+#           file://musb-dma-iso-in.eml;patch=1 \
+#           file://musb-support-high-bandwidth.patch.eml;patch=1 \
+           file://mru-fix-timings.diff;patch=1 \
+           file://mru-fix-display-panning.diff;patch=1 \
+           file://mru-make-dpll4-m4-ck-programmable.diff;patch=1 \
+           file://mru-improve-pixclock-config.diff;patch=1 \
+           file://mru-make-video-timings-selectable.diff;patch=1 \
+           file://mru-enable-overlay-optimalization.diff;patch=1 \
+#           file://musb-fix-ISO-in-unlink.diff;patch=1 \
+#           file://musb-fix-multiple-bulk-transfers.diff;patch=1 \
+#           file://musb-fix-endpoints.diff;patch=1 \
+           file://dvb-fix-dma.diff;patch=1 \
+           file://0001-Removed-resolution-check-that-prevents-scaling-when.patch;patch=1 \
+           file://0001-Implement-downsampling-with-debugs.patch;patch=1 \
+           file://sitecomwl168-support.diff;patch=1 \
+           file://musb-rxtx.patch;patch=1 \
+           file://0001-SDIO-patches-to-put-some-card-into-into-platform-dev.patch;patch=1 \
+           file://0002-Add-a-very-basic-platform-driver-module-to-bring-up-.patch;patch=1 \
+           file://0003-Remove-old-msm_wifi-hack-as-the-temp-platform-driver.patch;patch=1 \
 "
+
+# AUFS2 Patches - Used by ausf2-27 recipe to build as a module.
+
+SRC_URI_append = " \
+           file://aufs2/aufs2-base.patch;patch=1 \
+           file://aufs2/aufs2-standalone.patch;patch=1 \
+"           
+
+# Temp Keypad Patches for FN.
+
+SRC_URI_append = " \
+           file://keypad/0001-input-remove-old-twl4030keypad-to-replace-it-with-ma.patch;patch=1 \
+           file://keypad/0002-Input-add-support-for-generic-GPIO-based-matrix-keyp.patch;patch=1 \
+           file://keypad/0003-Input-matrix_keypad-make-matrix-keymap-size-dynamic.patch;patch=1 \
+           file://keypad/0004-Input-matrix-keypad-add-function-to-build-device-key.patch;patch=1 \
+           file://keypad/0005-Input-add-twl4030_keypad-driver.patch;patch=1 \
+           file://keypad/0006-input-hacks-updates-for-mainline-twl4030-driver.patch;patch=1 \
+           file://keypad/0007-some-hackish-Fn-handling-for-testing.patch;patch=1 \           
+"       
        
 S = "${WORKDIR}/git"