omap3-pandora-kernel2: update
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel2_3.2-pandora.bb
index 1f850ac..e855b92 100644 (file)
@@ -4,13 +4,13 @@ LICENSE = "GPLv2"
 COMPATIBLE_MACHINE = "omap3-pandora"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-PR = "r19"
+PR = "r27"
 
 # we already build 2.6 kernel using OE infrastructure, and
 # as we don't know how to build another one into the same image
 # (especially out-of-tree modules), we just package manually prebuilt one
 # git://git.openpandora.org/pandora-kernel.git , branch pandora-3.2
-# commit: 7a86414d402959803aae2576377ce1b158bc41ef
+# commit: 32717b39f181e256647b0bcda5768b59884d2f5b
 # out-of-tree modules are built from:
 # http://git.openpandora.org/cgi-bin/gitweb.cgi?p=sgx.git
 # http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_modules.tar.bz2
@@ -22,9 +22,16 @@ do_install() {
   cp -a ${S}/boot ${D}/
   cp -a ${S}/lib ${D}/
   rm -f ${D}/lib/modules/*/modules.dep*
+
+  # dupes from other OE packages..
+  rm -rf ${D}/lib/firmware/vicam
+  rm -rf ${D}/lib/firmware/ttusb-budget
 }
 
+PACKAGES =+ "linux-firmware-media"
+
 FILES_${PN} = "boot lib"
+FILES_linux-firmware-media = "lib/firmware"
 
 pkg_postinst_${PN} () {
   # this will cause depmod to be run on next boot
@@ -59,5 +66,5 @@ boot.txt / autoboot.txt) or the system might not start after reboot."
 }
 
 PACKAGE_STRIP = "no"
-SRC_URI[md5sum] = "9d5d4438a5df7d300b8ede40896af5d5"
-SRC_URI[sha256sum] = "d25db14612257d115ce07c05ece3ca006f633171d80c49d0031592e9a46dc231"
+SRC_URI[md5sum] = "2ea15d513d9865027226b7ed8656d63c"
+SRC_URI[sha256sum] = "6569c0ac603f3da87789779e6daa14df25750d8d77c975018310cf410b01a0cf"