omap3-pandora-kernel2: don't include modules.dep
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel2_3.2-pandora.bb
index 2bbb869..1f850ac 100644 (file)
@@ -4,28 +4,38 @@ LICENSE = "GPLv2"
 COMPATIBLE_MACHINE = "omap3-pandora"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-PR = "r4"
+PR = "r19"
 
 # we already build 2.6 kernel using OE infrastructure, and
 # as we don't know how to build another one into the same image
 # (especially out-of-tree modules), we just package manually prebuilt one
-SRC_URI = "http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_r4.tar.bz2"
+# git://git.openpandora.org/pandora-kernel.git , branch pandora-3.2
+# commit: 7a86414d402959803aae2576377ce1b158bc41ef
+# out-of-tree modules are built from:
+# http://git.openpandora.org/cgi-bin/gitweb.cgi?p=sgx.git
+# http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_modules.tar.bz2
+SRC_URI = "http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_${PR}.tar.bz2"
 
 S = "${WORKDIR}"
 
 do_install() {
   cp -a ${S}/boot ${D}/
   cp -a ${S}/lib ${D}/
+  rm -f ${D}/lib/modules/*/modules.dep*
 }
 
 FILES_${PN} = "boot lib"
 
 pkg_postinst_${PN} () {
+  # this will cause depmod to be run on next boot
+  rm -f /lib/modules/`uname -r`/modules.dep
+  sync
+
   if ! grep -q '[[:blank:]]/[[:blank:]]*ubifs' /proc/mounts; then
-    test -e /media/PANDORABOOT/uImage && oldkernel=/media/PANDORABOOT/uImage
-    test -e /media/PANDORABOOT/uImage-3 && oldkernel=/media/PANDORABOOT/uImage-3
-    test -e /media/BOOT/uImage && oldkernel=/media/BOOT/uImage
-    test -e /media/BOOT/uImage-3 && oldkernel=/media/BOOT/uImage-3
+    for dir in `ls -d /media/*boot* 2> /dev/null` `ls -d /media/*BOOT* 2> /dev/null`; do
+      test -e $dir/uImage && oldkernel=$dir/uImage
+      test -e $dir/uImage-3 && oldkernel=$dir/uImage-3
+    done
 
     if test -n "$oldkernel"; then
       cp /boot/uImage-3 $oldkernel
@@ -37,6 +47,7 @@ where your kernel is booted from (usually set in boot.txt / autoboot.txt)."
 copy it to the location where kernel is booted from (usually set in \
 boot.txt / autoboot.txt) or the system might not start after reboot."
     fi
+    sync
     if test -n "$DISPLAY"; then
       zenity --info --text "$msg"
     else
@@ -48,5 +59,5 @@ boot.txt / autoboot.txt) or the system might not start after reboot."
 }
 
 PACKAGE_STRIP = "no"
-SRC_URI[md5sum] = "9e64a15f07c05c0dcb6970a3bdff226e"
-SRC_URI[sha256sum] = "1d037d2e2d2c2be2a4a37b51a00623f950169b2431d5657191169b767bdbd8d8"
+SRC_URI[md5sum] = "9d5d4438a5df7d300b8ede40896af5d5"
+SRC_URI[sha256sum] = "d25db14612257d115ce07c05ece3ca006f633171d80c49d0031592e9a46dc231"