pandora-misc: bump
[openpandora.oe.git] / recipes / gtk / gtk-touchscreen-mode-enable.bb
index 08a0185..46607d2 100644 (file)
@@ -2,15 +2,21 @@ DESCRIPTION = "Enable gtk-touchscreen-mode in gtkrc"
 
 RDEPENDS = "gtk+"
 
-PR = "r2"
+PR = "r1"
 
 ALLOW_EMPTY_${PN} = "1"
 PACKAGE_ARCH = "all"
 
 pkg_postinst() {
 #!/bin/sh
-mkdir -p $D${sysconfdir}/gtk-2.0
-touch $D${sysconfdir}/gtk-2.0/gtkrc
-sed -i /gtk-touchscreen-mode = 1/d $D${sysconfdir}/gtk-2.0/gtkrc
-echo 'gtk-touchscreen-mode = 1' >> $D${sysconfdir}/gtk-2.0/gtkrc
+mkdir -p ${sysconfdir}/gtk-2.0
+touch ${sysconfdir}/gtk-2.0/gtkrc
+sed -i /gtk-touchscreen-mode = 1/d ${sysconfdir}/gtk-2.0/gtkrc
+echo 'gtk-touchscreen-mode = 1' >> ${sysconfdir}/gtk-2.0/gtkrc
 }
+
+pkg_postrm() {
+#!/bin/sh
+sed -i /gtk-touchscreen-mode = 1/d ${sysconfdir}/gtk-2.0/gtkrc
+}
+