f5ec0fdc911fa56accd3a25c065679ea0b726fa5
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r34"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13   abiword \
14   evince \
15   claws-mail \
16   swfdec swfdec-gnome swfdec-mozilla \
17 #  firefox \
18   gnumeric \   
19 #  gimp \
20   networkmanager network-manager-applet \ 
21 #  synergy \
22   vnc x11vnc angstrom-x11vnc-xinit \
23   xchat \
24 #  xournal \
25   arora \
26 "
27
28 BLUETOOTH_GUI = " \
29   gnome-bluetooth \
30 "
31
32 IM_CLIENT = " \
33   pidgin \
34   libpurple-protocol-msn \
35   libpurple-protocol-yahoo \
36   libpurple-protocol-icq \
37   libpurple-protocol-aim \
38 "
39
40 DISPMAN = " \
41   slim \
42   slim-op-themes \
43 "
44
45 FONTS = " \
46   font-adobe-75dpi \
47   fontconfig fontconfig-utils font-util \
48   ttf-arphic-uming \
49   ttf-dejavu-common \
50   ttf-dejavu-sans \
51   ttf-dejavu-serif \
52   ttf-dejavu-sans-mono \
53   ttf-liberation-sans \
54   ttf-liberation-serif \
55   ttf-liberation-mono \
56   xorg-minimal-fonts \
57 "  
58
59 # Any default games we want to ship.
60 GAMES = " \
61 #  scummvm \
62 #  frozen-bubble \
63 #  gnome-games \  
64 #  numptyphysics \
65 "
66
67 GNOME_APPS = " \
68 #  gnome-mplayer \
69 #  gcalctool \ 
70   gnome-keyring gnome-keyring-pam-plugin \
71   gksu \
72 "
73
74 GNOME_GTK = " \
75 #  gnome-icon-theme \
76 #  angstrom-gnome-icon-theme-enable \
77 "
78
79 GSTREAMER = " \
80 #  gstreamer-ti \
81   gst-ffmpeg \
82   gst-omapfb \
83 #  gst-plugin-pulse \
84   gst-plugin-xvimagesink \
85   gst-plugins-base-meta \
86 #  gst-plugins-good-meta \
87 #  gst-plugins-bad-meta \
88 #  gst-plugins-ugly-meta \
89   gst-plugin-gles \
90   qt4-plugin-phonon-backend-gstreamer \
91 "
92
93 ICON_THEME = " \
94   hicolor-icon-theme \
95   elementary-icon-theme \
96   elementary-icon-theme-enable \
97 "
98
99 LAUNCHERS = " \
100 #  netbook-launcher-efl \
101   pandora-libpnd-minimenu \
102   pandora-pmenu \
103 "
104
105 PANDORA = " \
106   pandora-first-run-wizard hsetroot \
107   pandora-scripts \
108   pandora-wallpaper-official pandora-wallpaper-community \
109   pandora-xfce-defaults \
110   pandora-midori-defaults midori \
111   libgles2d \
112   pandora-misc \
113 "
114
115 PERL = " \
116   perl \
117   task-perl-module-all \
118   libnet-dbus-perl \
119   libxml-parser-perl \
120   libxml-twig-perl \
121 "
122
123 PULSEAUDIO = " \
124 #  pulseaudio-alsa-wrapper \
125 #  pulseaudio-esd-wrapper \
126 #  pulseaudio-module-gconf \
127 #  libasound-module-ctl-pulse \
128 #  libasound-module-pcm-pulse \
129 "
130
131 PYTHON_LIBS = " \
132   python-shell \
133   python-pygtk \
134   python-pycairo \
135   gnome-vfs-plugin-http \
136   gnome-vfs-plugin-ftp \
137 "
138
139 QT_SELECTED = " qt4-x11-free \
140 "
141 # qt4-x11-free"
142 # qt4-x11-free-gles"
143
144 #PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
145
146 QT_SUPPORT = " \
147   ${QT_SELECTED} \
148   qt4-plugin-imageformat-jpeg \
149   qt4-plugin-imageformat-gif \
150   libqtopengl4 \
151 "
152
153 # We want all of the Qt metapackage (for dev use) without the demos/examples.
154 BAD_RRECOMMENDS += " \
155   ${QT_SELECTED}-demos \
156   ${QT_SELECTED}-examples \
157 "
158
159 TOTEM = " \
160 #  totem \
161 #  totem-browser-plugin \
162 #  totem-plugin-bemused \
163 #  totem-plugin-gromit \
164 #  totem-plugin-media-player-keys \
165 #  totem-plugin-ontop \
166 #  totem-plugin-properties \
167 #  totem-plugin-screensaver \
168 #  totem-plugin-skipto \
169 #  totem-plugin-thumbnail \
170 "
171
172 TOUCHSCREEN = " \
173   gtk-touchscreen-mode-enable \
174   libgtkstylus \
175 #  xinput-calibrator \
176 "
177
178 XFCE46_BASE = " \
179   xfce4-dev-tools \
180   xfwm4 \
181   xfwm4-theme-default \
182   xfce-utils \  
183   xfce4-session \     
184   xfconf \
185   xfdesktop \
186   xfce4-panel \
187   xfce4-power-manager \
188   \
189   gtk-xfce-engine \
190   \
191   xfce4-panel-plugin-actions \
192   xfce4-panel-plugin-clock \
193   xfce4-panel-plugin-iconbox \
194   xfce4-panel-plugin-launcher \
195   xfce4-panel-plugin-pager \
196   xfce4-panel-plugin-separator \
197   xfce4-panel-plugin-showdesktop \
198   xfce4-panel-plugin-systray \
199   xfce4-panel-plugin-tasklist \
200   xfce4-panel-plugin-windowlist \   
201   xfce4-settings \
202   xfce-terminal \
203   thunar \
204 "
205
206 XFCE46_EXTRAS = " \
207   xfce4-notifyd \
208   xfce4-mixer \
209   xfce4-appfinder \
210   xfce4-battery-plugin \
211   xfprint \    
212   orage \
213   squeeze \
214   ristretto \
215   mousepad \ 
216   gigolo \
217 "
218
219 XFCE_THEMES = " \
220   xfwm4-theme-daloa \
221   xfwm4-theme-moheli \
222   xfwm4-theme-kokodi \
223   xfwm4-theme-sassandra \
224   xfwm4-themes \
225 "
226
227 XSERVER_BASE = " \
228   ${XSERVER} \
229   dbus-x11 \
230   desktop-file-utils \
231   iso-codes \
232   mime-support \
233   notification-daemon inotify-tools \
234   xauth \
235   xdg-utils \
236   xhost \
237   xinetd \
238   xinit \
239   xlsfonts \
240   xrdb \
241   xrefresh \
242   xset \
243   xvinfo \
244   devilspie \
245   encodings \
246   xterm \
247   xmodmap \
248 "
249
250 RDEPENDS_${PN} = " \
251   task-pandora-core \
252   angstrom-x11-base-depends \
253   ${ANGSTROM_EXTRA_INSTALL} \
254   ${APPS} \
255   ${BLUETOOTH_GUI} \
256   ${IM_CLIENT} \
257   ${DISPMAN} \
258   ${FONTS} \
259   ${GAMES} \  
260   ${GNOME_GTK} \
261   ${GNOME_APPS} \
262   ${GSTREAMER} \
263   ${ICON_THEME} \
264   ${LAUNCHERS} \
265   ${PANDORA} \
266   ${PERL} \
267   ${PULSEAUDIO} \
268   ${PYTHON_LIBS} \
269   ${QT_SUPPORT} \
270   ${TOTEM} \
271   ${TOUCHSCREEN} \
272   ${XSERVER_BASE} \
273   ${XFCE46_BASE} \
274   ${XFCE46_EXTRAS} \
275   ${XFCE_THEMES} \
276   \
277   rxvt-unicode \
278 #  xst \
279 #  suspend-desktop \
280 #  teleport \
281   gdk-pixbuf-loader-png \
282   gdk-pixbuf-loader-xpm \
283   gdk-pixbuf-loader-jpeg \
284   pango-module-basic-x \
285   pango-module-basic-fc \
286   xcursor-transparent-theme \   
287   xterm \
288   jaaa nmap iperf \
289 #  gnuplot \
290 "