5b49a6c0e8e48f76f347ad2f97490d8d26af81d9
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r2"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13   abiword \
14   claws-mail \
15   swfdec swfdec-gnome swfdec-mozilla \
16   firefox \
17   gnumeric \   
18   gimp \
19   networkmanager network-manager-applet \ 
20   synergy \
21   vnc \
22   x11vnc angstrom-x11vnc-xinit \
23   xterm \
24   xchat \
25 "
26
27 BLUETOOTH_GUI = " \
28 #  blueman \
29   gnome-bluetooth \
30 "
31
32 IM_CLIENT = " \
33   pidgin \
34   libpurple-protocol-msn \
35   libpurple-protocol-yahoo \
36   libpurple-protocol-icq \
37   libpurple-protocol-aim \
38 "
39
40 DISPMAN = " \
41   slim \
42   slim-op-themes \
43 "
44
45 FONTS = " \
46   font-adobe-75dpi \
47   fontconfig fontconfig-utils font-util \
48   ttf-arphic-uming \
49   ttf-dejavu-common \
50   ttf-dejavu-sans \
51   ttf-dejavu-serif \
52   ttf-dejavu-sans-mono \
53   ttf-liberation-sans \
54   ttf-liberation-serif \
55   ttf-liberation-mono \
56   xorg-minimal-fonts \
57 "  
58
59 # Any default games we want to ship.
60 GAMES = " \
61   scummvm \
62 "
63
64 GNOME_APPS = " \
65 #  epiphany epiphany-extensions \
66 #  evince \  
67   gnome-games \
68   gnome-mplayer \
69   gcalctool \ 
70   gnome-keyring gnome-keyring-pam-plugin \
71 "
72
73 GNOME_GTK = " \
74 #  hicolor-icon-theme \
75 #  gnome-icon-theme \
76 #  angstrom-gnome-icon-theme-enable \
77 "
78
79 GSTREAMER = " \
80   gst-ffmpeg \
81   gst-omapfb \
82   gst-plugin-pulse \
83   gst-plugins-base-meta \
84 #  gst-plugins-good-meta \
85   gst-plugins-bad-meta \
86 #  gst-plugins-ugly-meta \
87 "
88
89 ICON_THEME = " \
90   elementary-icon-theme \
91   elementary-icon-theme-enable \
92 "
93
94 PANDORA = " \
95   pandora-first-run-wizard hsetroot \
96   pandora-scripts \
97   pandora-wallpaper-official pandora-wallpaper-community \
98   pandora-xfce-defaults \
99   pandora-xmms-defaults xmms \
100 "
101
102 PERL = " \
103   perl \
104   task-perl-module-all \
105   libnet-dbus-perl \
106   libxml-parser-perl \
107   libxml-twig-perl \
108 "
109
110 PULSEAUDIO = " \
111   pulseaudio-alsa-wrapper \
112   pulseaudio-esd-wrapper \
113   pulseaudio-module-gconf \
114   libasound-module-ctl-pulse \
115   libasound-module-pcm-pulse \
116 "
117
118 QT_SUPPORT = " \
119   qt4-x11-free \
120 #  qt4-x11-free-gles \
121 "
122
123 TOTEM = " \
124   totem \
125   totem-browser-plugin \
126   totem-plugin-bemused \
127   totem-plugin-gromit \
128   totem-plugin-media-player-keys \
129   totem-plugin-ontop \
130   totem-plugin-properties \
131   totem-plugin-screensaver \
132   totem-plugin-skipto \
133   totem-plugin-thumbnail \
134 "
135
136 TOUCHSCREEN = " \
137   xf86-input-tslib \
138   gtk-touchscreen-mode-enable \
139   libgtkstylus \
140 "
141
142 XFCE46_BASE = " \
143   xfce4-dev-tools \
144   xfwm4 \
145   xfwm4-theme-default \
146   xfce-utils \  
147   xfce4-session \     
148   xfconf \
149   xfdesktop \
150   xfce4-panel \
151   \
152   gtk-xfce-engine \
153   \
154   xfce4-panel-plugin-actions \
155   xfce4-panel-plugin-clock \
156   xfce4-panel-plugin-iconbox \
157   xfce4-panel-plugin-launcher \
158   xfce4-panel-plugin-pager \
159   xfce4-panel-plugin-separator \
160   xfce4-panel-plugin-showdesktop \
161   xfce4-panel-plugin-systray \
162   xfce4-panel-plugin-tasklist \
163   xfce4-panel-plugin-windowlist \   
164   xfce4-settings \
165   xfce-terminal \
166   thunar \
167 "
168
169 XFCE46_EXTRAS = " \
170   xfce4-notifyd \
171   xfce4-mixer \
172   xfce4-appfinder \
173   xfprint \    
174   midori \
175   orage \
176   squeeze \
177   ristretto \
178   mousepad \ 
179   gigolo \
180 "
181
182 XFCE_THEMES = " \
183   xfwm4-theme-daloa \
184   xfwm4-theme-moheli \
185   xfwm4-theme-default-4.0 \
186   xfwm4-theme-default-4.2 \
187   xfwm4-theme-default-4.4 \
188   xfwm4-theme-kokodi \
189   xfwm4-theme-moheli \
190   xfwm4-theme-sassandra \
191   xfwm4-theme-stoneage \
192   xfwm4-theme-therapy \
193   xfwm4-theme-tyrex \
194   xfwm4-theme-wallis \  
195 "
196
197 XSERVER_BASE = " \
198   ${XSERVER} \
199   dbus-x11 \
200   desktop-file-utils \
201   iso-codes \
202   mime-support \
203   notification-daemon inotify-tools \
204   xauth \
205   xdg-utils \
206   xhost \
207   xinetd \
208   xinit \
209   xlsfonts \
210   xrdb \
211   xrefresh \
212   xset \
213   xvinfo \
214   devilspie \
215 "
216
217 RDEPENDS_${PN} = " \
218   task-pandora-core \
219   angstrom-x11-base-depends \
220   ${ANGSTROM_EXTRA_INSTALL} \
221   ${APPS} \
222   ${BLUETOOTH_GUI} \
223   ${IM_CLIENT} \
224   ${DISPMAN} \
225   ${FONTS} \
226   ${GAMES} \  
227   ${GNOME_GTK} \
228   ${GNOME_APPS} \
229   ${GSTREAMER} \
230   ${ICON_THEME} \
231   ${PANDORA} \
232   ${PERL} \
233   ${PULSEAUDIO} \
234   ${QT_SUPPORT} \
235   ${TOTEM} \
236   ${TOUCHSCREEN} \
237   ${XSERVER_BASE} \
238   ${XFCE46_BASE} \
239   ${XFCE46_EXTRAS} \
240   ${XFCE_THEMES} \
241   \
242   rxvt-unicode \
243   xst \
244   suspend-desktop \
245   teleport \
246   gdk-pixbuf-loader-png \
247   gdk-pixbuf-loader-xpm \
248   gdk-pixbuf-loader-jpeg \
249   pango-module-basic-x \
250   pango-module-basic-fc \
251   xcursor-transparent-theme \   
252   mime-support \
253   xterm xmms \
254   jaaa nmap iperf gnuplot \
255   x11vnc angstrom-x11vnc-xinit \
256 "